Topic Title: AMD Radeon HD7990 Problem with games
Topic Summary: AMD Radeon HD7990 and I5-4670K crashing on games.
Created On: 11/23/2013 02:45 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/23/2013 02:45 PM
User is offline View Users Profile Print this message

Author Icon
garrisonlowe
Peon

Posts: 1
Joined: 11/23/2013

I just got a new PC from ibuypower and i have a Radeon Hd 7990 with a i5-4670k, i have Windows 7 64-bit and everything was fine at first, but the i tried to play games and it gave me a blue screen every time i tried to launch a game. Games like Sniper Elite v2, sleeping dogs and ect... and on top of that it freezes every 10 min on a game and i have to turn my whole computer of then back on. My drivers are all up to date, but im thinking about changing to a beta version to see if it helps. crysis 3 boots up fine and i can max it out nut it freezes when i play over 10 min at a tim. What should i do? Do you think my card is overheated? Should i buy a seperate GPU cooler or something? My CPU is water cooled, and the whole things gets hot on games like Tomb Raider and Crysis 3. Those are the only games ive been able to play so far. And they still get occasional freezes, but not as bad. So please help! 

Thanks

-Garrisonlowe

 11/23/2013 03:15 PM
User is offline View Users Profile Print this message

Author Icon
Earnhardt
Case Modder

Posts: 878
Joined: 09/11/2008

Contact ibuypower,they built it.



-------------------------

AMD Phenom II 1100t @4.0Ghz /Asus sabertooth 990fx/2x Gigabyte 3G 7950's in crossfire/500G samsung 840 ssd/16G G-Skill Ripjaw 1600/2-samsung 24" monitors 1920X1200/Corsair AX1200W psu/W7 pro 64,G19 keyboard,Roccat kone pure mouse,Cooler master HAF932,Corsair H100i water cooler,Zalman ram cooler.Sound Blaster X-Fi Titanium Fatal1ty Champion Series,Logitech Z5500 speakers,Roccat Kave 5.1 headset.

 11/23/2013 08:02 PM
User is offline View Users Profile Print this message

Author Icon
Thanny
Alpha Geek

Posts: 1340
Joined: 07/13/2009

Sounds a lot like an unstable overclock.  I concur with contacting the builder of the system, if you didn't do any overclocking yourself.

 

Statistics
84831 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.