Topic Title: Driver Issues
Topic Summary:
Created On: 12/02/2013 09:17 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/02/2013 09:17 AM
User is offline View Users Profile Print this message

Author Icon
lansucker
Peon

Posts: 2
Joined: 12/02/2013

Hello to all AMD Forum users,

since the latest Driver Update (13-9_win7_win8_64_dd_ccc_whql) my system seems to struggle a lot under higher performance, here is how the problems show up:


1. After booting my system every game I play has heavy FPS drops, laggy gameplay and isnot enjoyable at all. Here are 2 screenshots where the FPS are shown.

http://i.imagebanana.com/img/l6owq7qp/FPS_ISSUE_D31.jpg

http://i.imagebanana.com/img/mw55tvre/FPS_ISSUE_BF41.jpg

As you can see the FPS are really bad, and thats not because of my rig, it has to do sth with the latest driver, how I know?

After playing a bit Diablo3 my AMD Driver crashed, had a blackscreen for a short amount of time (3 seconds), but after that my screen turned on again and I had my normal, pre driver install, FPS.

http://i.imagebanana.com/img/4v3kzufq/FPS_ISSUE_D32.jpg

http://i.imagebanana.com/img/tvvwpfq4/FPS_ISSUE_BF42.jpg

That means, everytime I want to play normal, I have to reinstall the drivers (causing the black screen as well, after that the FPS are fixed again), or I have to wait until the driver crashes. And I have to do that every time I reboot the PC, so that is not really problem solving. I tried everything, I reinstalled the drivers hundreds of time and so on, my onboard graficcard is disabled in the bios as well.

I could just use the older AMD drivers where I don't have that problem at all, but I get an error message every time when I try to play BF4 (You have to update the driver etc).

System:
Prozessor: Intel Core i5-3470 CPU@3,2GHz
Ram: 8 GB
GPU: ATI Radeon 7850 2048mb

 

Sorry for the bad language, didn't use english for a long time so it became a bit rusty

 12/07/2013 03:48 AM
User is offline View Users Profile Print this message

Author Icon
lansucker
Peon

Posts: 2
Joined: 12/02/2013

Bump

Statistics
85405 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.