Topic Title: AMD Radeon 7850 1GB Sapphire Low FPS Issues
Topic Summary:
Created On: 12/09/2013 11:10 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/09/2013 11:10 PM
User is offline View Users Profile Print this message

Author Icon
Erudes
Peon

Posts: 2
Joined: 12/09/2013

Hello people! I really don't know what else to do, I have tried anything, I'm gonna explain to you from the beginning. One month ago I built a RIG to play:

Motherboard Asus M4A88TD-M

AMD Phenom II x4 955

8GB DDR3 Kingston RAM

1TB WD Caviar Black

AMD Radeon 7750 1GB GDDR5

PSU Antec 620W Pro

Windows 8 Pro 64 Bits

Latest Drivers from aything

The thing is there was low FPS in ALL GAMES, including Mortal Kombat Komplete Edition at 720p, AC4 and CoD Ghosts. When I say low FPS I mean really low, 15 FPS at gameplay and low settings.

I updated my Mobo BIOS, and the problem was solved, nevertheless it started to appear again.

Two days ago, I changed my video card to AMD Radeon 7850 1GB GDDR5, and STILL problems persists, I can't play decently any game, I uninstalled the drivers and re-installed even the beta versions, and I cannot even fight on Mortal Kombat whis is depressing.

DirectX is also up-to-date. What else should I try to do? Please help, I'm going crazy with this

 12/11/2013 11:25 PM
User is offline View Users Profile Print this message

Author Icon
manupa14
Peon

Posts: 19
Joined: 10/10/2012

silly question what resolution do you play at? and how big is your monitor? are you oc the processor? at how many GHz is it running? did you buy the gpu new or used? 

 12/11/2013 11:26 PM
User is offline View Users Profile Print this message

Author Icon
manupa14
Peon

Posts: 19
Joined: 10/10/2012

I came up with something else. MOTHERBOARD. Are you running in a x16 pci express 2.0 slot? have u checked? u can do it from gpu -z. If you could take a screeen it'd be wonderful

 12/12/2013 08:51 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12478
Joined: 04/17/2008

Create a second HD partition and install (but do not activate) a clean installation of Windows and see if the issue persists.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 12/13/2013 08:56 PM
User is offline View Users Profile Print this message

Author Icon
Erudes
Peon

Posts: 2
Joined: 12/09/2013

Well I managed to solve it, I reset my BIOS settings to default and everything runs good now, I really don't know what did I touch to mess it up.

Anyway here some images:

AC High FPS

http://i43.tinypic.com/nqd5ba.jpg

AC Low FPS

http://i40.tinypic.com/v5fzbn.jpg

Idle FPS

http://i44.tinypic.com/24lsymb.jpg

Mortal Kombat High FPS

http://i39.tinypic.com/dxd3d0.jpg

Mortal Kombat Low FPS

http://i42.tinypic.com/291gy2b.jpg

Tomb Raider High FPS

http://i44.tinypic.com/2q2iozn.jpg

Tomb Raider High FPS 2

http://i41.tinypic.com/sl7nnp.jpg

a) Is it normal Tomb Raider uses 99% of GPU?

b) Is it normal AC4 Black Flag it's locked at 30FPS?

Thank you very much for your time!

Statistics
85471 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.