Topic Title: BF4 Crossfire Issues?
Topic Summary:
Created On: 12/10/2013 01:41 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/10/2013 01:41 PM
User is offline View Users Profile Print this message

Author Icon
__Turbo__
Peon

Posts: 4
Joined: 12/10/2013

I need your help.

The other day I posted this describing my new crossfire setup.

Today I am running a single card due to some difficulties I have been having.

Here are some details:

I am trying to crossfire a 7870 and a 7850 using this motherboard and a 750 watt Rosewill Hive PSU and an i5 3470 3.2 GHz CPU.

When I first set this up I was only using CCC and I was getting 60 FPS on BF4 with all settings on ultra with vsync on

I took the advice of an individual that commented on my original post and downloaded RadeonPro, this is when things started going south. My FPS dropped to 40

I uninstalled RP and downloaded MSI afterburner, overclocked my 7850 to match the 7870. It seemed to help a little bit but I was getting some artifacts on the right side of my windows start-up screen. I down-clocked my 7870 lower than my 7850. This helped for a couple games but I started getting the 40 FPS again.

I am running the latest Beta Drivers

What can I do to fix this so I can use both cards instead of having one in a box?

Thank you so much for your help!

Statistics
84136 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.