Topic Title: R9 290X Black Screen of Death
Topic Summary: Lets band together and Sue AMD
Created On: 02/01/2014 01:02 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/01/2014 01:02 AM
User is offline View Users Profile Print this message

Author Icon
triiton77
Peon

Posts: 1
Joined: 01/31/2014

I have 2 R9 290x cards that black screen on me when I am gaming or when I am working in Word it even did it once all by itself. AMD has put out a sub par product that was falesly advertiesed to many thousands of people who now like me have GPUs that will not work.  I have tried all different drivers (yes the beta too), new installs of Win 7 nothing helps.  I have to hard reboot my computer which it will eventually fry.   I have 1300 worth of useless junk that I can not take back and RMA will do no good.  AMD needs to  either buy back these cards we all have, or fix the issue promptly. They may have money to sit around but I could use my 1300 buck back.  Any gamer lawyers out there who want to start a class action lawsuit, Im on board.  I have read many thousands of  stories of people out there with the same issue.  they are sitting on hundreds and thousands of dollars lost.

And before any trolls start, no not overclocked, no not over heated, new system, new 1200 watt PSU. New everything.  And btw, I have already sent a whole system back for RMA because the hard reboot fried it.  

AMD fix this or buy your junk back.

Any good lawyers out there?

 02/01/2014 01:08 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12334
Joined: 04/17/2008

I'll give you $20 for the pair.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 02/04/2014 07:13 PM
User is offline View Users Profile Print this message

Author Icon
plunderclat
Peon

Posts: 3
Joined: 02/04/2014

I have found a fix for the crashing on the R9 290x!!!!!!! (well one of a few things fixed it but I'm sure of which one did it!!!! in windows goto your RUN box and type 'msconfig' and click on the start up tap. Look for the catalyst control centre and UNCHECK that box. you don't want that loading up on boot.  run the game.

Please let me know how that fairs, and if it didn't work, its' likely to be one of the hardware managers that you have installed, because the other things I deselected for bootup was anything to do with the motherboard software (i use the m5a9xx EVO R.2.0 and there were a few monitors installed with this)

Really hope this helps someone because it has been my absolute bain since i installed 14.1 and used mantle.

I have done a few things to get it to crash so that I didn't waste your time such as - ran every map, tabbed out of game and ran hardware monitors, used my browser etc. nothing has caused the game to crash since I carried out the *above* steps.

So pleased bf4 runs so nice now lol

(btw if you're using an intel processor, disable the on board gpu)



-------------------------
GIGABYTE R9 290x - AMD FX 8350 black edition - 8gb corsair vengeance 1866mhz - Samsung 840 pro 240gb x2 - 750w 50A single rail CoolerMaster psu - m5a99x evo R2.0.

No O/C!
Statistics
84707 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.