Topic Title: Borderlands 2 Screen Tearing Problems
Topic Summary: MSI R9 290X
Created On: 03/15/2014 07:03 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/15/2014 07:03 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 03/15/2014


I'm getting screen tearing problems on Borderland 2. Basically, every game I own works fine with zero tearing, I tried turning on V-sync and it does help, but there's still a lot left and I can't play the game for more than an hour as the screen tearing is giving me really bad headache. I've got my PC connected to my Samsung UE40F7000 HDTV which does handle games pretty good, just not Borderlands 2? I've also tried turning on Game Mode on the TV, but it doesn't solve the problem. My Asus MX239H - Monitor doesn't make any difference either? A few days ago, I upgraded to Windows 8.1 Pro and did a clean install, hoping it would remove any issues, sadly it didn't.

My GPU is running the latest drivers, DirectX and Windows updates, so that's not causing any issues. I had this screen tearing problem on my old Asus 6670 GDDR5 GPU, and I thought the card was not good enough to run Borderlands 2, so put it down to that, but like I said upgrading the GPU has not solved the problem and it confirms that it's not an issue with the new card. Also, I tried turning on AMD Catalyst triple buffering, but no improvement is made. 

To be honest, I have absolutely ran out of ideas to what is causing the problem


To make this easier, here is my PC specs;


NZXT Phantom 410 Full Tower Case.

ASUS CrossHair V Formula-Z Motherboard.

MSI Radeon R9 290X Twin Frozr IV 4GB GDDR5.

AMD FX 8350

SanDisk Extreme 240GB SSD.

Corsair H100i CPU Water Cooler.

Seagate 1TB Hard Drive.

Corsair Vengeance (4X4GB) 16GB DDR3 1600MHz.

LG Blu-ray drive.

OCZ Fatal1ty 750W PSU.

Akasa USB 3.0 Dive with card reader.


Can anyone help?

 03/16/2014 01:55 AM
User is offline View Users Profile Print this message

Author Icon
Alpha Geek

Posts: 1559
Joined: 07/13/2009

What version of Catalyst?

I found in some of the later 13.x betas that vsync no longer worked properly in Borderlands 2.  The frame rate would go to 120fps instead of 60fps, and there'd be plenty of tearing.


93160 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.