Topic Title: Games Crashing??
Topic Summary:
Created On: 03/18/2014 01:01 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/18/2014 01:01 AM
User is offline View Users Profile Print this message

Author Icon
etchersoy23
Peon

Posts: 11
Joined: 02/15/2014

My games keep crashing on me, and it's really annoying when I try to play them and then sudden crash... My games are: BO2 (all of them),Civilization V, and Battlefield 3. I've been searching around the internet for about 3 Months now trying to find a solution to my problem. 

Specs are:
AMD Radeon HD 7700 (GPU) 

AMD Fx-8350 - Eight-Core processor. (CPU)

Windows 8.1[64-bit] (OS)

1TB (Harddrive)

8GB (RAM)

The interesting thing is that all my other games do not crash, and I have no idea why, but every game that crashes are from a game case instead of installing off of Steam. Please help me I tried

1.) Reinstalled the drivers
2.) Going to the Beta Drivers (AMD 14.2 Beta Drivers)
3.) Changing the compatibility modes on all of the games.
4.) Crying wondering why this computer isn't doing it's job D: 
That's about all I can remember.. Oh and, Running in administrator mode.. I done other things like Caching as well. 

 03/18/2014 03:06 AM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Well I 14.3 Beta is available, I have BF2/3/4 and have no issues with those games. I do play those off Origin, and have you check on EA about this issue.

The other software to check is PunkBuster, which you can get the latest at:

http://websec.evenbalance.com/downloader/download.php?file=1

I'm not sure what else with BF3 could be an issue, but check it.

I use the 13.12 WHQL drivers and only have used the beta drivers a couple of times. I will wait for Mantle access with the next WHQL release for BF4.

 

 



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 03/18/2014 09:31 AM
User is offline View Users Profile Print this message

Author Icon
booman
Peon

Posts: 3
Joined: 03/18/2014

Hello guys! I'm a new AMD user here. My specs are:

Processor: FM2: AMD A10 7850 kaveri
Mobo: FM2+ Gigabyte sniper 88x
RAM: G SKILL Ripjaws X Series 8GB (2 x 4GB) 1866
HDD Internal: WD Caviar Blue 1TB SATA3       
HDD SSD: Corsair Force LS 60GB
Casing Aero cool gt strike x one
PSU: Hec Cougar SL 600w 80+ Certified (Non-Modular)

I'm using win 8.1 and installed the latest bios and amd catalyst 14.3 beta. Everytime I play/ install/ watch movies it hangs. I can see distorted graphics with a looping sound.

 

i dont know what to do anymore. everything is brandnew and it should work fine.

 

thanks for the help!

Statistics
85482 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.