Topic Title: Random FPS drop in ALL Games
Topic Summary: Frame drops for 15-30 seconds then goes back to normal then goes back again for a short time.
Created On: 05/23/2014 07:30 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/23/2014 07:30 AM
User is offline View Users Profile Print this message

Author Icon
neonhon
Peon

Posts: 5
Joined: 07/23/2012

I can't remember when this started happening but it happens very often when I play any game (even low-end games). 

So I was playing CS:GO (Counter Strike:Global Offensive) and my average FPS is hitting to like 200-300+ and maximum was like 400 (All on very low settings). And suddenly it just drops to 30-40 FPS for like 15-30 seconds then goes back to normal. And then after 3-4 minutes it drops again. 

I've already reformat my computer and reinstalled my GPU drivers several times but I saw no signs of changes. Already tried using Razer Gamebooster but it didn't helped. And if you're talking about CPU Temp. problem. My CPU Temp is hitting at 25°C-35°C. GPU Temp is at 35°C-40°C. So there's no way it's a temperature problem.

Helps are happily appreciated.

PC Specs posted below on my signature.

Thanks.

 

Catalyst Version: 14.4 (14.10.1006-140417a-171099C)

Display: LG E2042C 75 Hz

Games: CS:GO, League of Legends, Dota 2, Battlefield 3, Team Fortress 2, Crysis 2

BIOS: American Megatrends Inc., Version V17.15, Date 4/28/2013



-------------------------

  • MSI 760GM-P21 (FX AM3+)



  • AMD FX-8350 Eight-Core Processor 4.0 GHz



  • ASUS Radeon R9 270x DCUII TOP



  • 1xG.Skill RipJaws X DDR3 4GB 1600MHz 



  • Windows 7 Ultimate SP1 64-bit




  • Cooler Master N300 mid-tower



  • Cooler Master Seidon 120v



  • HuntKey MAX 600w



Edited: 05/23/2014 at 07:45 AM by neonhon
 05/23/2014 01:39 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7253
Joined: 11/13/2009

Is your computer power plan set to 'performance'? In CCC..Overdrive, do you have the power slider set to +20?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 05/23/2014 11:20 PM
User is offline View Users Profile Print this message

Author Icon
neonhon
Peon

Posts: 5
Joined: 07/23/2012

Did those. Tested but still, no difference. I'm sure it's from the power but I can't figure it out which one should I fix.



-------------------------

  • MSI 760GM-P21 (FX AM3+)



  • AMD FX-8350 Eight-Core Processor 4.0 GHz



  • ASUS Radeon R9 270x DCUII TOP



  • 1xG.Skill RipJaws X DDR3 4GB 1600MHz 



  • Windows 7 Ultimate SP1 64-bit




  • Cooler Master N300 mid-tower



  • Cooler Master Seidon 120v



  • HuntKey MAX 600w

Statistics
85708 users are registered to the AMD Support and Game forum.
There are currently 8 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.