Topic Title: AMD blanket removal utility/Drivers/Warframe
Topic Summary: MY GOD WHAT HAVE I DONE?!
Created On: 05/23/2014 04:32 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/23/2014 04:32 PM
User is offline View Users Profile Print this message

Author Icon
IHWIP
Peon

Posts: 3
Joined: 05/23/2014

I've been having a bit of a driver issue on my Windows 7-64 bit machine. I have an AMD Radeon HD 6670 and recently decided that I should try to completely reinstall the drivers because this computer is about 5 years old now and well...the video has never been reliable.

 

I thought it would be a good idea to use the AMD blanket removal utility. BAD IDEA. Instead of just removing the AMD drivers it seems to have removed every single driver from my system. Sort of. After letting windows find the generic ones, rebooting about 10 times and reinstalling the latest drivers I am back up and running. There is just one problem.

 

I only play one game that has high end graphics. Warframe. For some reason I cannot get it to work again. I have gone back to driver 13.9 and plan on rolling back to 13.4 to see if that helps but to no avail. Every time I open the game it is only a matter of time until the screen goes black. This results in 1 of 2 things: With the newest driver it would hard reboot my computer. Anything older I can alt-tab back to the desktop and force close Warframe. I have tried shutting off all acceleration, lowering the settings as much as possible, I am stumped.

 

If anyone has any suggestions or could point me in the right direction I would greatly appreciate it.

 05/23/2014 04:50 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7493
Joined: 11/13/2009

No, I am stumped. Have you tried a system restore to a point before you used the AMD uninstall everything?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 05/23/2014 10:32 PM
User is offline View Users Profile Print this message

Author Icon
IHWIP
Peon

Posts: 3
Joined: 05/23/2014

Unfortunately I did not think of that and now it no longer has any restore points that far back. Fuuuuuuuuuuuuu

 05/24/2014 03:08 PM
User is offline View Users Profile Print this message

Author Icon
IHWIP
Peon

Posts: 3
Joined: 05/23/2014

OK so...I have installed the most up to date drivers, turned on overdrive and set everything else back to default. This allows me to launch Warframe and get it going but if I try to enter a mission it freezes very rapidly. I am assuming this is because the 3d animation becomes much more complex.

I also am crashing in Minecraft too. Didn't try it until now. I am not sure whether to address this as a software problem anymore. Should I try blasting my video card with some canned air? I mean...I have freshly reinstalled everything except my damned OS at this point and I am still at square one.

 

If I am forced to buy a new video card I won't be surprised.

Statistics
87675 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.