Topic Title: fps buzz/whine in background all applications
Topic Summary: Getting a constant whining noise that changes depending on fps
Created On: 06/14/2014 12:01 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/14/2014 12:01 AM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

So I recently built a new computer, and in ANY application I seem use, I get a constant high-pitched whining / bussing sound. From my testing, it gets louder the more fps I have, and the pitch also seems to change dpending on it, but less directly. (I've been using fraps to see how many fps I am getting.)

It was first noticable with Skyrim (~1000fps, except in menus screens, where I got ~2000fps), but once I noticed it, I realized that I heard it in every game I played, and even in non-game applications (chrome, steam, etc...). I am not sure why I do not hear it when  I have not opened any windows, but I expect it is because the desktop is locked at 30fps or something like that, so it is too quiet.

Now, I would go into all my games and lock the fps at 60 or use vsync and be done with it, but I can still hear it well at 60fps. I've tried changing audio settings, tried other audio ports on my machine, and tried other audio devices, all to no avail. Keep in mind that this is coming from speakers, and is NOT coil whine. The computer itself is very quiet, just the hum of the fans.

 

I am posting this here because it is related to my fps. If I should move this, or if I should ask somewhere else, do let me know!

My system:

 

Motherboard: Gigabyte GA-990FXA-UD7

Processor: AMD FX-8350

Videocard: Radeon R9 290 XFX D.D.E.

RAM: Crucial Ballistix 16GB (2x 8GB) DDR3 1600

PSU: EVGA SuperNOVA 1000 G2

Standard SSD and HDD, standard optical drive, all in Define XL R2 Case.

I also have a Thermaltake Water 3.0 Extreme liquid cooler installed on the Processor.

 

I am running Win 7 Ult w/ latest drives. 

 

**No overclocking or other funny business is going on here, either.**

 06/14/2014 01:36 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12188
Joined: 04/17/2008

How do you know it's not coil whine?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 06/14/2014 01:53 AM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

It's coming through speakers - whatever device I plug in wherever. I remove any speakers, or take off headphones, and I cannot hear it at all.

 

**Also, it does not sound like coil whine. The sound is admittedly slightly similar, but I would not read into it, because it is quite a bit more different as well.



Edited: 06/14/2014 at 02:00 AM by xurol
 06/14/2014 02:28 AM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12188
Joined: 04/17/2008

Then it has to be caused by EM or RF interference, something electronics are not supposed to do but XFX isn't exactly top dog in quality these days. Try moving the video card to another slot to add some distance between it and the sound chip. If that doesn't work, RMA would be your only option.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 06/14/2014 09:03 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Does it sound like this ?

 

http://www.youtube.com/watch?v=HP73edpQwgc

 

Also, see this:

http://www.head-fi.org/t/595094/help-extremely-loud-buzzing-from-speakers-when-gpu-is-active

 

V-sync can help with this, but it also greatly depends on the gpu's capacitors' quality (voltage leaking ?).

 

Check your whole equipment's EMI shielding and quality as black_zion suggested. Low quality cables, connectors and speakers can produce noises. Try another gpu to make sure if it's gpu related only.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/14/2014 09:45 AM
User is offline View Users Profile Print this message

Author Icon
HoneyBadger84
Grinding Levels

Posts: 197
Joined: 06/10/2014

Have you tried updating whatever sound device you're using's drivers? On board audio in particular sometimes has issues that updating drivers for it fixes.



-------------------------

CPU: i7 3930k @ 4.6GHz 1.29V (Corsair H110-cooled) ~ Motherboard: Asus RoG Rampage IV Extreme 
RAM: G.Skill Sniper Gaming Series (4x4GB 2133MHz, CL9) ~ PSU: Corsair AX 1200W ~ Case: Enermax Fulmo GT
GPUs: 3x HIS R9 290X Reference (Core) Editions in TriFire, Max Load Temps: 71C/70C/71C during OC testing :-P

 06/14/2014 07:07 PM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

"Try moving the video card to another slot to add some distance between it and the sound chip."

Opened it up, moved videocard to another slot and moved wires around so they don't come as close as often, and the sound is quiter, but still present enough to make me very unwilling to use audio esp. in games.

I should mention the I am using onboard audio, and that sound sound gets even quiter (but only slightly still!) if I plug in directly to the motherboard instead of to the plug built into the case.

 

"Does it sound like this ?"

No, not really.

"Also, see this:"

Okay, here are a few ideas. I'll see what I can do in this direction. I do not have access to another videocard, so that is out of the question, but I may be able to disable it's usage (did it once before, after moving it to another slot I needed to update my BIOS before it actually started using it again,) and I will also try changing outlets (currently have everything plugged into APC power backup) and disabling all sound 'devices' so we will have to see.

 

"Have you tried updating whatever sound device you're using's drivers?"

Tried multiple devices. All drivers are up-to-date.

 

 06/14/2014 07:42 PM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

Tried moving to another outlet, no effect, tried disable all audio devices, no effect, could not bypass the videocard even when reproducing the situation exactly as it had happened...

 

I saw something about HDMI cables... I have a new DVI cable in the mail, but right now I am using HDMI, so we can hope that the new cable will resolve the problem/help with it. Even after making things quiter, the buzz is audible even while in my browser (runs at 30fps), so limiting fps / using vsync won't act as a cheap solution. I also took a look at the quality of cables and grounding, and as far as I can tell with a bit of research, it looks pretty good.

IF the cable does not help, probably will get a replacement videocard, might even get the 290x just to have something diffferent. But first I will wait on the cable.

 06/14/2014 09:29 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7029
Joined: 11/13/2009

In your control panel...go to sound > advanced and set your default to 44100hz and disable all enhancements. See if that works.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 06/14/2014 10:42 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Originally posted by: xurol Tried moving to another outlet, no effect, tried disable all audio devices, no effect, could not bypass the videocard even when reproducing the situation exactly as it had happened...

 

 

 

I saw something about HDMI cables... I have a new DVI cable in the mail, but right now I am using HDMI, so we can hope that the new cable will resolve the problem/help with it. Even after making things quiter, the buzz is audible even while in my browser (runs at 30fps), so limiting fps / using vsync won't act as a cheap solution. I also took a look at the quality of cables and grounding, and as far as I can tell with a bit of research, it looks pretty good.

 

IF the cable does not help, probably will get a replacement videocard, might even get the 290x just to have something diffferent. But first I will wait on the cable.

 

 

What kind of speakers/ amplifier are you using for audio output ?



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/16/2014 06:42 PM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

"In your control panel...go to sound > advanced and set your default to 44100hz and disable all enhancements. See if that works."

Like I said, I've tried adjusting these settings, and setting it exactly as you say has no effect.

 

"What kind of speakers/ amplifier are you using for audio output ?"

I've tried multiple devices, including regular old external speakers and headphones of multiple varieties. Using regular 3.5mm plug, both on the case front and directly to the motherboard, with only a slight volume difference btween the locations.

 

*UPDATE*: DVI cable has arrived, and although my picture is nicer, the real problem persists.



Edited: 06/17/2014 at 04:39 PM by xurol
 06/19/2014 07:04 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Get or test good quality speakers with good quality analog cables.

 



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/20/2014 07:30 PM
User is offline View Users Profile Print this message

Author Icon
SomeRandomUser
Peon

Posts: 16
Joined: 06/19/2014

Originally posted by: xurol 

 

I should mention the I am using onboard audio, and that sound sound gets even quiter (but only slightly still!) if I plug in directly to the motherboard instead of to the plug built into the case.

 

 

This comment caught my eye.  You mention that you've tried both the case's built-in audio connector as well as plugging directly into the motherboard.  That suggests you have installed the long internal cable that runs from the case's audio plug to the motherboard.  Have you tried disconnecting that internal audio cable entirely?  I only mention it because those cables are generally thin and completely unshielded.  This makes them act like little antennas inside your case picking up all sorts of RF noise.  It's possible that even when you have your speakers/headphones plugged directly into the motherboard, that internal cable could still be piping RF noise back into the audio circuitry.  I know it's a bit of a long shot, but try disconnecting that internal case audio cable entirely.

This really sounds like an RF noise issue, but (as you've discovered) identifying both the source and the fix can be a real pain.  The downside to getting a new gpu is that, if the problem is actually with your onboard audio chip being too sensitive, a new gpu would do the same thing.  A cheaper test might be to get some inexpensive, basic PCIe sound card and stick it in the very last PCIe slot on your motherboard, far away from your gpu.  Then fully disable the onboard audio chip in the BIOS.

 

 06/20/2014 11:18 PM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

Originally posted by: SomeRandomUser   Have you tried disconnecting that internal audio cable entirely?  I only mention it because those cables are generally thin and completely unshielded.  This makes them act like little antennas inside your case picking up all sorts of RF noise.  It's possible that even when you have your speakers/headphones plugged directly into the motherboard, that internal cable could still be piping RF noise back into the audio circuitry.  I know it's a bit of a long shot, but try disconnecting that internal case audio cable entirely.

 

This really sounds like an RF noise issue, but (as you've discovered) identifying both the source and the fix can be a real pain.  The downside to getting a new gpu is that, if the problem is actually with your onboard audio chip being too sensitive, a new gpu would do the same thing.  A cheaper test might be to get some inexpensive, basic PCIe sound card and stick it in the very last PCIe slot on your motherboard, far away from your gpu.  Then fully disable the onboard audio chip in the BIOS.

 

 

 

 

I'll first try disconnecting the case cable, and see how that works. If it does, I might just use the motherboard jack, or see about getting a better sheilded cable / a soundcard. But this sounds promising! Will get back to you soon.

 06/25/2014 08:09 PM
User is offline View Users Profile Print this message

Author Icon
xurol
Peon

Posts: 7
Joined: 06/13/2014

Disconnecting the case cable does indeed stop the noise completely. I'll see about getting some sort of shielding for it or some other workaround, but I can pretty confidently say that the videocard is most likely emmiting some sort of EM wave and the case audio cable is acting like an antenna. 

Possible solutions might be:

Getting a soundcard,

Getting another videocard,

Getting some sort of shielding for the cable,

Unplugging the case cable entirely and using the motherboard jack in the back,

Moving the cable (I personally don't have the space) to another area in the case,

Replacing the case / case cable / getting an extension that is properly shielded and plugging it into the motherboard and coiling up the built in cable out of the way, instead.

 06/27/2014 02:52 AM
User is offline View Users Profile Print this message

Author Icon
Thanny
Elite

Posts: 1296
Joined: 07/13/2009

There are a number of sound cards which have shielding on them that would prevent this issue from affecting them.  They also typically sound drastically better than onboard sound.  I use an Asus Xonar Phoebus myself.

 

 06/27/2014 08:41 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Originally posted by: Thanny There are a number of sound cards which have shielding on them that would prevent this issue from affecting them.  They also typically sound drastically better than onboard sound.  I use an Asus Xonar Phoebus myself.

 

 

 

 

Sorry for bumping.

Can you recommend one or two more, of good quality ?

I'm kinda interested at the moment.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

 06/27/2014 03:21 PM
User is offline View Users Profile Print this message

Author Icon
zipsi
Case Modder

Posts: 978
Joined: 11/22/2010

Using Asus Xonar Essence ST myself and it's a keeper, there are very few sound cards on the market that match the quality (It's a Stereo soundcard, although you can upgrade it with an expansion card for 7.1). And about that EM interference, the case HAS to be grounded, otherwise you won't know if the components still have a charge in them, even after every cable is removed, which could fry up components. I lost a hard drive in the past due to this, all it took was a spark.



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
 06/27/2014 03:31 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1038
Joined: 11/14/2010

Thanks, good feedback zipsi



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, sapphire HD 6990 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.6 RC2 june23

Statistics
84124 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.