Topic Title: Windows 8.1 Modern Apps (Metro Apps) crashing to desktop
Topic Summary: Most modern apps do not work after Catalyst since Win 8.1
Created On: 06/14/2014 04:09 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/14/2014 04:09 AM
User is offline View Users Profile Print this message

Author Icon
ITWebGuy
Peon

Posts: 5
Joined: 06/14/2014

Graphics Card
Sapphire Radeon R9 290X running at stock speeds when running Modern Apps (Metro Apps) apps crash to desktop.
 Using iGPU intel HD 4600. apps and games work fine.


AMD Catalyst Driver Version, and Driver History

Currently 14.6, previously used 14.4 and 13.2. ß This version modern modern apps run fine.
 
Operating System

Windows 8.1.1 Pro x64

Issue Details
Use any Radeon card from HD 7xxx series and above and install any Catalyst driver after 13.2. ModernThe issue is that about 95% of Modern Apps {Metro Apps) will open, appear to load and crashes to desktop. But the app is still running in memory. On 8.1.1 crashes and minimizes to desktop, you can click on app again to maximize, it starts to loads and crashes to desktop. Only Modern App that has worked day one (since 8.0) is Zombie HQ. please look at event log and problem report logs on bottom.

Games run good. No issues there, runs fast and 3D gaming is good too, can hit max of 60 fps

Motherboard or System Make & Model
Asus Maximus Formula 6 Z87 Chipset


Power Supply

Corsair TX850M

http://www.corsair.com/en/tx-series-modular-tx850m-80-plus-bronze-certified-850-watt-high-performance-modular-power-supply


Display Device(s) and Connection(s) Used
Samsung series 6 3D LED smart TV 1080p ,  HDMI 1.4 cable. Blue ray / DVDRW


Applications and Games
with issues.

Xbox video, Netflix, 98 percent of games downloaded via windows store app. On catalyst version 13.2 I do not get this issue.

On 8.1.1 Modern Apps crash and minimizes to desktop, you can click on app again to maximize from the task bar, it starts to loads and crashes to desktop at this point I right click on task and close. Only Modern App that has worked day one (since 8.0) is Zombie HQ. go figure lol

I am always using the latest versions of modern apps, I have removed apps using powershell, cleared cache, wsreset, synced licences…

CPU Details - I7 4770K, 4 cores, running at 3.5 - 4.2 turbo, using stock voltages and BLCK,

Motherboard BIOS Version
-ASUS BIOS 1402

System Memory Type & Amount
- 16GB Corsair Dominator platinum 2.66 GHz @ 1.65 V

Additional Hardware
 Segate Hybrid 8GB SSD + 1 TB 64MB Cache no case fans,  no other regular PCIE cards. There is one dedicated PCIE for WLAN card that comes with the motherboard.


Additional Details
- System us up to date, ran SFC scans.Defender plus Hitman Pro scans come up clean.

Used Asus PC diags to stress test all components and all core components are well within tolerances. System motherboard has a mem test built in to motherboard and that checks out good even at 2666 MHz @ 1.65V.

Here are event log errors. Problem reporting has been sent via problem reporting since 8.1

Please note the faulty module name on these.

Here are some event log error reports:

Faulting application name: wwahost.exe, version: 6.3.9600.17031, time stamp: 0x53085927

Faulting module name: atidxx64.dll, version: 8.17.10.560, time stamp: 0x537ea1cf

Exception code: 0xc0000005

Fault offset: 0x000000000006f403

Faulting process id: 0xd0c

Faulting application start time: 0x01cf877366694f39

Faulting application path: C:\Windows\system32\wwahost.exe

Faulting module path: C:\Windows\system32\atidxx64.dll

Report Id: aa5b9261-f366-11e3-82a3-54271e32d2cb

Faulting package full name: Microsoft.ZuneVideo_2.2.902.0_x64__8wekyb3d8bbwe

Faulting package-relative application ID: Microsoft.ZuneVideo

Faulting application name: Game.exe, version: 0.0.0.0, time stamp: 0x520f857b

Faulting module name: atidxx32.dll, version: 8.17.10.560, time stamp: 0x537ea45a

Exception code: 0xc0000005

Fault offset: 0x0005fad5

Faulting process id: 0xc7c

Faulting application start time: 0x01cf877fcf199f61

Faulting application path: C:\Program Files\WindowsApps\Microsoft.HaloSpartanAssault_1.5.0.0_x86__8wekyb3d8bbwe\Game.exe

Faulting module path: C:\Windows\SYSTEM32\atidxx32.dll

Report Id: 0d36ca53-f373-11e3-82a3-54271e32d2cb

Faulting package full name: Microsoft.HaloSpartanAssault_1.5.0.0_x86__8wekyb3d8bbwe

 

 

 

 

 

Problem Reports Details

 

Description

Faulting Application Path:              C:\Windows\System32\WWAHost.exe

 

Problem signature

Problem Event Name:                      MoAppCrash

Package Full Name:                          Microsoft.ZuneVideo_2.2.902.0_x64__8wekyb3d8bbwe

Application Name:                           praid:Microsoft.ZuneVideo

Application Version:                         6.3.9600.17031

Application Timestamp:                   53085927

Fault Module Name:                      atidxx64.dll

Fault Module Version:                      8.17.10.560

Fault Module Timestamp:                537ea1cf

Exception Code:                                c0000005

Exception Offset:                              000000000006f403

OS Version:                                        6.3.9600.2.0.0.256.48

Locale ID:                                           1033

Additional Information 1:                1c55

Additional Information 2:                1c553bafa675c4b7e4b8ad3b516bc89b

Additional Information 3:                a9ff

Additional Information 4:                a9ffb992819903a68755ac8895455b3f

 

Extra information about the problem

Bucket ID:                                          3e1daeb9b30d216dbaeca6fed05977b7 (98831161482)

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Description

Faulting Application Path:              C:\Program Files\WindowsApps\Microsoft.HaloSpartanAssault_1.5.0.0_x86__8wekyb3d8bbwe\Game.exe

 

Problem signature

Problem Event Name:                      MoAppCrash

Package Full Name:                          Microsoft.HaloSpartanAssault_1.5.0.0_x86__8wekyb3d8bbwe

Application Name:                           praid:App

 06/14/2014 04:38 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7491
Joined: 11/13/2009

Right here



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 06/14/2014 07:56 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Alpha Geek

Posts: 1351
Joined: 11/14/2010

Can this app diagnostic tool help you ?

 

http://www.eightforums.com/tutorials/20291-windows-store-apps-troubleshooter-fix-apps-windows-8-a.html

 

 

You can try reregister Windows Store:

http://www.eightforums.com/tutorials/35231-store-re-register-windows-8-8-1-a.html

 

Reinstall apps if necessary.

Check for firewall/ anti-virus conflicts or corrupted entries.

 

I've heard reports that "AMD Dual Core Optimizer" can cause problems as well.

 

 

If it is actually a graphics driver issue, i suggest you clean install the latest catalyst driver.

 

You can also try  previous driver packages from AMD



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.11.2 beta



Edited: 06/14/2014 at 08:03 AM by backFireX64
 06/20/2014 06:03 PM
User is offline View Users Profile Print this message

Author Icon
ITWebGuy
Peon

Posts: 5
Joined: 06/14/2014

Hello,

Catalyst 13.12 works, i have clean installed and i will try to remove dual core optimizer, but that driver works with 13.12. Dont know why they cant figure out what they need to do to get latest drivers to work. I have reset store, app troubleshooter always has be do device troubleshooting and it states that it thinks my video card drivers are out of date, which it is the latest driver.

Seems like AMD developers can't even have windows OS recognize their software as the latest version. I have tried every diver including betas since after the only stable release 13.12 that worked with windows 8.1

They also have issues with netflix and Silverlight. I have been using ATI cards since late 90's and am a MCSA tech, to me this is not acceptable and I am 100% certain that it is poorly debuged device drivers.

 06/20/2014 06:35 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Alpha Geek

Posts: 1351
Joined: 11/14/2010

Have you tried reregistering the store and then reinstalling all the metro apps that have trouble launching ?

 

It fixed some problems i recently had with a w8.1 pc.

 

Unfortunately, if the store is corrupted and can't be repaired, only an os reinstall will solve the problem.

If it is strictly a driver issue then wait for the upcoming driver and see if that fixes it.

Metro app crashes are usually related to corrupt installation files, corrupt registry entries, administration priviliges issues (a new admin account can bypass this), or firewall conflicts.

 

Test and post back.

Thanks.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.11.2 beta

Statistics
87660 users are registered to the AMD Support and Game forum.
There are currently 8 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.