Topic Title: Watch Dogs crash with Crossfire enable
Topic Summary:
Created On: 06/16/2014 10:14 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/16/2014 10:14 PM
User is offline View Users Profile Print this message

Author Icon
tonylemos
Peon

Posts: 1
Joined: 06/14/2014

My Watch Dogs crash after Ubisoft Logo Screen, I update the drivers, try the beta driver but no solution. If I disable the Croosfire the game runs like Minecraft, very pixelated.

OS: Windows 8.1 Pro x64

Motherboard: Asus P8P67

Processor: Intel(R) Core(TM) i7-3770

Memory: 16GB DDR3 1333 Kingston

Video Card: 2 AMD Radeon HD 6700 Series (Crossfire on)

 

Is anyone having the same problem? 

Anything I can do or better wait a new driver and pray for it to work?

Bets regards
 06/16/2014 10:58 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 13076
Joined: 04/17/2008

Doesn't matter how good the drivers get you're not going to play Watch_Dogs with much detail enabled on a pair of 6700 series cards. I would say upgrade to new ones but at x16/x4 your motherboard is unsuited for Crossfire, so I would say upgrade to a single 280X.

-------------------------
AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ultimate x64
 06/17/2014 06:45 AM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Ubergeek

Posts: 1860
Joined: 11/14/2010

Originally posted by: tonylemos My Watch Dogs crash after Ubisoft Logo Screen, I update the drivers, try the beta driver but no solution. If I disable the Croosfire the game runs like Minecraft, very pixelated.

 

OS: Windows 8.1 Pro x64

 

Motherboard: Asus P8P67

 

Processor: Intel(R) Core(TM) i7-3770

 

Memory: 16GB DDR3 1333 Kingston

 

Video Card: 2 AMD Radeon HD 6700 Series (Crossfire on)

 

 

 

Is anyone having the same problem? 

 

Anything I can do or better wait a new driver and pray for it to work?

 

Bets regards

 

Modify the GameProfile.xml (documents/ my games/ watch_dogs) to have ultra or medium config. settings, or try this:

 

http://forums.ubi.com/showthread.php/882948-Unable-to-play-with-AMD-HD6990s-mega-thread?p=9997284&viewfull=1#post9997284

 

If you manage to run the game, lower settings as required.

I personally get the same crash to desktop as you, if i leave the shader option to low (????).

Test and experiment yourself to isolate the issue.

 

In-game pixelation usually indicates to overheat issues, insufficient or bad vram, unstable overclock or faulty card.

A driver bug can also cause such problems, but less frequently.

 

Lastly, hundreds/ millions of people are waiting for a good patch from ubi.

Until then, don't expect drivers to do any miracles.

 

EDIT:      see this relevant thread as well:

http://forums.amd.com/game/messageview.cfm?catid=443&threadid=174132&enterthread=y



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (950mhz/ 1100mhz), coolermaster ultimate 900w PSU.
amd catalyst 14.12 Omega Driver



Edited: 06/17/2014 at 07:26 AM by backFireX64
Statistics
88926 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.