Topic Title: Can't believe Warcraft/Crossfire is still Broken
Topic Summary: 4 year gap from AMD and WOW still does not work and is now worse
Created On: 08/14/2014 07:17 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/14/2014 07:17 AM
User is offline View Users Profile Print this message

Author Icon
Denonite
Peon

Posts: 3
Joined: 08/14/2014

Well I left the AMD graphics family four years ago and one of the main reasons was that World of Warcraft was broken on Crossfoire/Eyefinity setup's. Moved to Nvidia and have had no issues.

Now I upgraded to a 280x to go with my 3 monitor setup, first thing I find - can't run full screen with DX11 enabled, have to drop back to DX9 - WTF it's 2014!

I'm in the beta for the Warloards of Dranor expansion and Blizzard have further pumped up the graphcs another notch so purchased another 280x and guess what - Warcraft does not use it, performance drops when crossfire is enabled.

AMD you really need to sort your drivers for WOW out this is unacceptible. User base may have dropped to only 6.8M players but this is still a big game and shoudl not have these issues.

Also having issues with BF4 in another post.



-------------------------

Intel 2500K @ 4.6GHz, 8GB Brucial Balistix Tracer 1866MHz RAM, 2 x 280X, Asus Sabretooth Z77MB, Corsair Force GT SSD, Windows 8.1

Statistics
88853 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.