Topic Title: FX-8350 Dead?
Topic Summary:
Created On: 11/25/2013 02:01 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/25/2013 02:01 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 11/25/2013

I'm presently trying to get my FX-8350 to work. My rig runs perfectly with my Phenom II X6 1075T in it, but as soon as I drop the 8350 in it refuses to post. I have a Gigabyte 990 FXA UD5 which supports AM3+ socket cpus. My motherboard revision is 1.0 and I previously flashed the bios revision to F11, which was well after support for AM3+ was added. I will try flashing to the latest, F12. I recieved an RMA from Newegg for my original 8350 and they approved it for replacement, but when I recieved the package I'm quite positive they sent me the same processor as it was in an opened package.

Any ideas what could be the issue here? My rig also consists of a 1000w psu and 8 gb of 1333 mhz ddr3 ram (G SKill). Just to make sure I contacted Gigabyte and they responded that my motherboard should indeed be working with the 8350. So they only thing I can think of is there is a possible incompatibility with my ram, or there is an issue with the 8350 and Newegg decided to send it back defective.

Edited: 11/25/2013 at 03:24 PM by Anbws11
 11/25/2013 04:11 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 675
Joined: 09/08/2013

I'd clear the CMOS, use just one DIMM in the appropriate slot and try the FX-8350 which should work with that mobo. Newegg may have checked the CPU in one of their PCs and confirmed that it functions properly, which it should as they are all tested just before they are placed in the box by AMD for shipping. If you need to remove the Vid card to switch the CPUs, be certain that all 12v power cables are firmly plugged into the Vid card after the CPU change.


Technical ignorance is NOT a destiny it is a choice. Do your homework so that you can make technically informed decisions and not be duped by advertising hype or mis-information stated as fact when its not.


 12/01/2013 07:31 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 35
Joined: 12/10/2008

As you noted there are two version of this board, rev 1 and rev 3 (you have rev 1, you said.)  There are always reasons that board revisions are done...  Still doesn't mean that your board won't support an FX, however. There could be something relative to the board's power handling that was upgraded in rev 3 to handle FX cpus, who knows?  But something was improved/corrected, no doubt about that.

It's worth remembering that the bios update doesn't "enable the AM3+ socket"--the board has had that from day one.  What the update does is enable the board to support the AM3+ FX cpus...which is an entirely different proposition. 

As AMDforME mentioned, NewEgg tests your cpu by putting it in a supporting board and if it runs and passes whatever diagnostic tests they run, they send it back--and that's a *good thing* as it allows you to know for certain that your cpu is OK and lets you mark it off your list.  However, Newegg may or may not (probably not) test it in your revision (or even brand) motherboard.  They probably would not do this unless you bought both from them in a combo deal--in which case Newegg is obligated to test both.  But it doesn't sound like you purchased these components at the same time from Newegg.

So, your cpu is working correctly.  That leaves only the motherboard.  The ram is certainly a possibility, so you should put at least one DIMM of something else in there just for testing purposes.  If your ram needs swapping then the board & cpu will run with the replacement ram--IF NOT, then although it by no means is certain, you should be looking at the motherboard.  If you like this board then get another, by all means, but specifiy *revision 3.*  That's just one more item you can check off.

I sympathize!  This is like lego blocks and you shouldn't have these problems. I bought my ram and motherboard and cpu separately and they all came together and worked first time and have ever since!  Good luck.













MSI 970a-G46
Win8.1 x64, UEFI install, version 2.6
FX-6300 @4.5GHz, stable, Turbo disabled, C&Q Enabled
8-gigs 1600MHz DDR3,2x4, 225fsb, 1800MHz effective, 1.5v
Boot: Seagate 320GB; WD 1TB Blue;2x500GB Barricudas=1TB RAID 0
Radeon HD 7850 2Gig
Lian-Li PC-V1200 case
Corsair 600W PSU, 1x 49a 12v rail





92815 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.