Topic Title: Latest AMD SATA driver fails vs. MS Standard driver - Am I doing something wrong?
Topic Summary:
Created On: 02/02/2013 11:28 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/02/2013 11:28 AM
User is offline View Users Profile Print this message

Author Icon
Sweeler
Peon

Posts: 2
Joined: 02/02/2013

Hi guys!

I haven't been using AMD since my good old 3400+ but now I'm back.

Unfortunately I seem to have run in to some problems with the SATA drivers.


With my Gigabyte 990FXA-UD 3 mobo I also got a brand new Corsair Neutron SSD drive. 

First off I of course changed controller to ACHI and the first thing I did after Windows 7 64 bit installation was to install AMD Chipset Driver 13.1.

After I did that i ran the Windows evaluation and got 6,7 on disk performance. Tried to change to the MS Standard ACHI driver and then I got 7,9. Once again tried the AMD driver and once again 6,7.

 Is it really that big difference? I really thought that the AMD driver would perform better or at least the same? Or is it just the evaluation or have I done something wrong here?

Would be happy if someone could give me an advice  

 02/02/2013 01:04 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12198
Joined: 04/17/2008

WEI is a useless performance metric. See the thread 4 below this one titled "Interesting observations of SSDs on AMD chipsets"

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 02/02/2013 02:39 PM
User is offline View Users Profile Print this message

Author Icon
Sweeler
Peon

Posts: 2
Joined: 02/02/2013

Thank you black_zion!

I did as you guys did in that thread:

 
Overall the AMD driver seems to be ahead most of the time!

So i'll guess i stick to the AMD driver, thanks for your reply black_zion! 

Statistics
84141 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.