Topic Title: Internal Drive showing as removable, anyway to fix?
Topic Summary:
Created On: 02/26/2013 01:29 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/26/2013 01:29 AM
User is offline View Users Profile Print this message

Author Icon
matthelm
Peon

Posts: 12
Joined: 01/21/2013

I recently rebuilt my dad's TV recording system with a new ASUS A85X chipset.  One of the internal drives (of 4) is showing as external, which means it's showing as removable in "safely remove hardware".  The only link I can find is one that the registry entries don't show in my system.

 

Anyone know a way to fix this one drive?  I did look in the device manager, and it's set True there, but should be False.

 

 03/14/2013 12:06 AM
User is offline View Users Profile Print this message

Author Icon
felix_w
Peon

Posts: 9
Joined: 01/27/2010

Check your BIOS settings under SATA Controller Options, if there is a Hot Plug Option available, disable it for the port you have connected the system disk.

If there is one option for all ports, then, again, de-select the Hot-Plug option, but you may not use the function for other disks connected in your system.

If you have msahci driver (haven;t installed the amd_sata driver) then there is a registry fix.

 03/18/2013 06:35 PM
User is offline View Users Profile Print this message

Author Icon
matthelm
Peon

Posts: 12
Joined: 01/21/2013

I'll double check the BIOS, but I don't remeber it there.  Plus, why would it only show 1 of 6 drives being external?

 

I'm using the AMD drivers.

 

 03/20/2013 07:47 PM
User is offline View Users Profile Print this message

Author Icon
go_for
Nerfed

Posts: 56
Joined: 10/21/2011

Check the manual, not all SATA ports are equal. Some are "dedicated" as for removable media/hot-plug.



-------------------------

an Alpha Geek @ AMD Processors Forums | 01/21/2006 | post count 3217

 03/25/2013 01:36 PM
User is offline View Users Profile Print this message

Author Icon
archanut
Peon

Posts: 3
Joined: 03/25/2013

Go to the Device Manager in windows and edit the propeties for the SATA controller and unckeck "Enable safely remove disk" options and restart.

 03/27/2013 03:25 PM
User is offline View Users Profile Print this message

Author Icon
matthelm
Peon

Posts: 12
Joined: 01/21/2013

Originally posted by: go_for Check the manual, not all SATA ports are equal. Some are "dedicated" as for removable media/hot-plug.

 

 

That would be the one that has an external port. 

The only settings in the manual are for 5-7 ports, and I'm using every port, so there should be 3 externals if this wasn't set to internal.  Only seeing the one.

 

I think this was set on the "drive" when it was formated on an extrnal port (different machine) and windows (not the drive) won't switch back, even though it's now internal.

 03/27/2013 03:26 PM
User is offline View Users Profile Print this message

Author Icon
matthelm
Peon

Posts: 12
Joined: 01/21/2013

Originally posted by: archanut Go to the Device Manager in windows and edit the propeties for the SATA controller and unckeck "Enable safely remove disk" options and restart.

 

 

No such setting on the SATA controller properties.

 

Statistics
84159 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.