Topic Title: SB950 RAID drivers for Windows 7 x64 installation
Topic Summary: After BSoD can not repair/clean install Windows 7 x64. Installer does not see array.
Created On: 08/09/2013 06:35 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/09/2013 06:35 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 08/09/2013




I own Asus M5A99X Evo and 2 x Kingston SSDNow V300 120GB disks.
They are attached to SATA_1 and SATA_2.
Disks are members of RAID 0.
I have Windows 7 x64 installed on my only RAID 0.
No CD/DVD drives.

Recently I got BSoD - STOP 7b and immediately it became present on every boot.
Can't access “Safe mode” either. Freezes after

First I decided to repair Windows. System restore did not detect the disk and drivers from the motherboard CD did not solve anything.

I tried all 3 drivers from Asus site - no result.

So I decided to make a fresh install. And problem repeated itself just as with system restore - Windows installer did not see the disk.

I've tried drivers from 3.2.1540.92 to latest I found on AMD website - 3.3.1540.35. No use.

So I thought drives are damaged. I created Hiren's Boot CD and it sees array and both partitions - System Reserved and other (let’s call it win partition) which contain Windows installation and data. I could even backup my important data to USB.

Ububtu installation also detects array and both partitions.

To double check I ran:
1. checkdisk on win partition and no errors where found
2. I disabled RAID and run “Western digital data lifeguard diagnostic” on each driver separately and both passed test
3. Ran Memtest86 which resulted in 2 passes with no errors.
This and the fact I could backup data seems to exclude hardware failure.

I also read hundreds of threads and even the "solved" ones could not help me.

Please help!

 08/09/2013 09:35 AM
User is offline View Users Profile Print this message

Author Icon
QB the Slayer
Master Looter

Posts: 346
Joined: 11/27/2012

I had a very odd occurance not too long ago.  Norton found a virus in one of my old driver packages and it was the ahcix64s.sys files in that package.  Now this was one from Gigabyte that I never use, so I just let Norton remove the files.  I just chalked it up to Norton being weird and making a very rare error...  I have not had a virus found on my computer in years, actually, I don't think I have ever had a virus. 


Anyway, I am not saying this is the reason, but you may want to look into viruses that target the AMD RAID drivers.  Your issue sounds like corrupt drivers.





CPU: AMD FX-8350.||.Cooler: Corsair H80i
MB: Gigabyte 990FXA-UD7.||.RAM: 8 GB Mushkin Blackline DDR3 2000MHz (7-10-8-27-1T)
Case: CoolerMaster HAF 932.||.PSU: Corsair HX750
GPU:Asus R9 270X DirectCU II TOP.||.Audio: Creative X-Fi Titanium Fatal1ty Pro w/ Logitech Z-5300e (5.1, 280W-RMS)
System Drive: 2xSamsung 840 Pro 128GB RAID0.||.Working Drive: 2xMushkin Chronos 60GB RAID0

93425 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.