Topic Title: AMD USB 3.0 eXtensible Host Controller - 0100 (Microsoft) driver for Win7x64
Topic Summary: Unable to find a driver for Windows 7
Created On: 08/12/2013 02:46 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/12/2013 02:46 PM
User is offline View Users Profile Print this message

Author Icon
P. Leiba

Posts: 1
Joined: 08/12/2013

I am searching for the AMD USB 3.0 eXtensible Host Controller - 0100 (Microsoft) Windows 7x64 driver. I downgraded an HP Pavilion TouchSmart All-In-One PC from Windows 8 to Windows 7 Pro x64. That device is the only one that I cannot seem to find a driver for. Everything else has been covered using either Microsoft Update or the latest chipset package from AMD.

I had another model of this AiO, with a slightly different MoBo (different Chipset), and the AMD download identified and loaded a driver for that USB 3.0, but not this one.

The Hardware ID's are as follows:

Compatible ID's are:

The Windows 8 drivers (for the exact same device hardware ID's) are provided by Microsoft, dated 9/19/2012, version 6.2.9200.16420. The components are:

I downloaded and installed the latest chipset driver from the AMD support site (version 13.4), which successfully loaded all my other chipset hardware drivers, except for the USB 3.0 one I am describing.  I even noted a BETA update on the site and tried that (I think it was something like 13.8).

The Motherboard is a Pegatron (special re-brand of Asus, I think for HP products) AAHD3-AT (FM2 Socket).  It uses an AMD Bolton-D3s chipset. The video set is AMD Radeon HD 7480D.  The computer is an HP Pavilion TouchSmart 23-f250 All-in-One.

If anyone can point me in the right direction to download this driver, I would appreciate it. It is currently listing as "Universal Serial Bus (USB) Controller, under "Other devices," in Device Manager. No driver loaded or available.

Thank you.

 09/22/2013 10:20 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 09/22/2013

Hi, I am reporting here my issues with latest 13.4 chipset package not updating well the Dell package on my Vostro3555 - I am sure its relate to your issue too:

There was huge problems to update chipset USB drivers on my Dell Vostro3555, which was solved finally by uninstalling with AMD Chipset 13_4 version, restarts and then installing latest dell A70M chipset support (DELL R309668 - older AMD version), with reinstalling older drivers first, then restarts, then uninstalling them, restarts and resintalling again, with checks of DeviceManager and possible manual uninstalling of corrupted versions. Simply, everything must be reversed to plain dell older version to USB30 starts working again to detect WIFI USB adapters. It seems that mass storage devices was OK even with corrupted USB30 drivers (cant remember no), there was problem particulary with AMD Root HUB driver not updated/matched to other parts of driver, IMHO.

Root cause can be that updated AMD USB HUB driver file wasnt installed properly with the update for some reason and the setup didnt reported no problem (13-4_vista_win7_win8_32-64_sb.exe)

Also, viewing finall setup log is impossible with any catalyst setup package at least on my system and I dont know the reason.


I tried to update the currently working dell A70M drivers again with AMD 13-4 package,Everything looked fine, but after restart, my wireless usb was not starting again (nothing reported or code 10 or 22, didnt remember but such codes was occuring in the middle sometimes)

So I tried to uninstall 13-4 package again immediatelly without restart - setup uninstaller hungs immediatell on some item (apparently amdusb30.sys as described later). Setup was unresponsive so was killed by taskman, then I restarted the machine, but shutdown was stalling and so I must force turn off the machine and tried AMD 13-4 uninstaller again after that. Now uninstaller detected that it has 3 items instaleld to uninstall (so NO AMD HUB item !!!) and everything went ok during uninstall and restart.

After restart, though, there was still installed NEW (13-4) version of amdhub30.sys and the HUB had exclamation point, so not working, although there were returned original DELL previous version drivers for remaining USB30 support (the controller). So I MANUALLY uninstalled the failing AMD HUB item and ALSO the 3.0 controllerin device manager with REMOVAL of files, as previously, the OLD installer was unable to touch new amdusb30.sys item and was showing some discrepany about installed items eighter, even that device manager showed some older versions. So, now again I did restart without ANY AMD USB3.0 support at all to do fres setup of old Dell A70M package.

After restart, double-checking that there is NO AMD USB30 support installed in device manager, I started the old Dell A70M setup, but here was only 3 USB related items noted as to be installed, so I instead restarted setup to UNINSTALL ALL USB related items (missing was USB DeviceDetector), but there was NO such item listed as installed at all too.

Then I restarted setup again to try to install at least 3 USB related items, hoping it will be ok after restart. Although, rerun of setup didnt showed the missing USB30 device detector item at all, I tried to plug my WIFI USB adapter (its 2.0 only) again and it started well finally.(I am almost sure there WAS 4th item, the device detector even with older Dell package though)

(BTW: message editor here doesnt work well in Win764 IE10)

Edited: 09/22/2013 at 10:32 AM by falken007
93124 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.