Topic Title: ATI Mobility Radeon HD 5470 : difficulties installing update, help please?!
Topic Summary:
Created On: 09/16/2012 08:25 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/16/2012 08:25 PM
User is offline View Users Profile Print this message

Author Icon
tsukami
Peon

Posts: 4
Joined: 09/16/2012

I have:

-notebook

-Dell

- studio 1558

-installed memory 8gb

- total c: capacity 582gb, total free 291gb

-intel core i7  Q740 @1.73GHz 1.73 GHz

-windows 7 64bit

-ati mobility radeon HD 5470

-driver date 11/18/2009

-driver version: 8.680.0.0

 

my issue is:

I can't get the update to properly install.  Ive had this laptop for a while now, and had an issue with the mouse cursor constantly blowing up in size, going to the mouse settings didn't solve anything and it didnt matter what application I had open, or what applications I didn't have running, the cursor would simply, 'poof' large, sometimes because of it the computer will crash, or go to a black screen then come back displaying that it had recoverd from a graphics issue.  It does it in game, crashing games, browsing internet, anything.  With a LOT of searching I had found a update for my ati driver, successfully updated it, and fixed everything! was even able to run skyrim on full graphics with no glitching THEN, a few months back, I had a hardrive failure and luckely my waranty covered it and gave me a new one, now I'm back to square one.  Same issues, messed up mouse, it crashes the laptop, my skyrim runs slower even on the lowest graphics, (not that I care about the game), but the cursor blowing up in size is a constant annoyance.  I have done a lot of searching, have download the update on AMD, and half way through I get a blue screen, then nothing.  I restart the computer and it tells me I have no driver at all.  So I have to do a system restore or try and roll back the driver to return it tot he way it was.  The download link for the update had also provided another update, one that fixes issues with installing the original update, I tried that first, and same thing, it goes to a blue screen then leaves me with no driver and I have to roll back.

 

I'm needing help with this issue.  Am I installing it incorectly?  All I do is simply click the download and let it run it's course with recomened settings.  Is there a different download I should be using?  Unfortunatly I no longer have the link from AMD to show which download I have been trying.  But I want a fix to this mouse and I remember the only fix was to update the driver, regardless, I want to be able to update my driver.

 

Statistics
85368 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.