Topic Title: Need urgent help with HD 6750 on Samsung NP700Z5A!
Topic Summary: AMD Radeon HD 6750 missing from dxdiag and Device Manager
Created On: 10/10/2012 02:36 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/10/2012 02:36 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 10/10/2012

Hi, I am new to the forum but I desperately need help with the graphics card on my new Samsung Chronus NP700Z5A-S09US!

Got the laptop in the post yesterday and immediately went tocheck dxdiag for the specs and graphics card. Dxdiag showed this: "Intel HD Graphics Family" instead of my Radeon HD 6750. However it DID show up im my Device Manager.

I tried downloading driver for it from AMD but got this error upon attempting installation: "AMD Catalyst Mobility cannot be downloaded due to incompatiable hardware/software on your computer". Eventually downloaded it formt he Samsung website, installed it what appears to be successfully but with no visible changes.

Went to tech support on Samsung website, where they advised me to do a basic system restore and then re-install the VGA_AMD ver 8.951.9.3000 Driver.

After some further trouble locating the Samsung Recovery System software on my computer (which turns out is missing) I re-installed Windows 7 (64bit) using the disc supplied with laptop.

After this my problems got worse!

Since the re-installation, my AMD Radeon HD 6750 and Intel HD Graphcs Family display adapters have been replaced by Standard VGA Graphics Adarper...!! (I was also missing networking drivers so I couldn't connect to the internet to download. Had to download drivers to a CD from another computer to install them on the Samsung) My screen resolution won't go above 1024 x 786.

The whole thing is driving me mad becuse I don't know how to fix it and nothing I try to do seems to work. I have tried downloading drivers from AMD but hey won't instal.

Someone please tell me what I'm doing wrong and how to fix this??

(Samsung tech support also suggested and re-imaging might fix the problem, but after already paying 135 Euro in Customs Duties for this machine, I don't really fancy sending it back to US for re-imaging at $39 + shipping!)

93344 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.