Topic Title: Unity does not load after installing fglrx-installer
Topic Summary:
Created On: 10/21/2012 05:35 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/21/2012 05:35 AM
User is offline View Users Profile Print this message

Author Icon
THpubs
n00b

Posts: 1
Joined: 10/21/2012

I have a laptop with ATI Radeon 6770M HD Hybrid graphics card. In Ubuntu 12.04, I installed the fglrx driver through "additional drivers" and it worked. (I can even switch GPUs). But in the new Ubuntu 12.10, after installing, Unity won't load.

Only the mouse and the wallpaper. If I initialize the settings sudo aticonfig --initial then after rebooting it gives a warning saying I'm in low graphics mode! How to fix this?

Even tried the drivers from AMD website (both the old 8.* and the new 9.* drivers)

Earlier i used software source to install the drivers. But when using the terminal, I got this warning :

- update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken

Full installation log :

- pubudu@lap1:~$ sudo apt-get install fglrx-updates
[sudo] password for pubudu:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
fglrx-amdcccle-updates
The following NEW packages will be installed:
fglrx-amdcccle-updates fglrx-updates
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 85.1 MB of archives.
After this operation, 254 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://lk.archive.ubuntu.com/ubuntu/ quantal/restricted fglrx-updates amd64 2:9.000-0ubuntu3 [79.4 MB]
Get:2 http://lk.archive.ubuntu.com/ubuntu/ quantal/restricted fglrx-amdcccle-updates amd64 2:9.000-0ubuntu3 [5,747 kB]
Fetched 85.1 MB in 16min 38s (85.3 kB/s)
Selecting previously unselected package fglrx-updates.
(Reading database ... 159905 files and directories currently installed.)
Unpacking fglrx-updates (from .../fglrx-updates_2%3a9.000-0ubuntu3_amd64.deb) ...
Selecting previously unselected package fglrx-amdcccle-updates.
Unpacking fglrx-amdcccle-updates (from .../fglrx-amdcccle-updates_2%3a9.000-0ubuntu3_amd64.deb) ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up fglrx-updates (2:9.000-0ubuntu3) ...
update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken
update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
update-initramfs: deferring update (trigger activated)
Loading new fglrx-updates-9.000 DKMS files...
First Installation: checking all kernels...
Building only for 3.5.0-17-generic
Building for architecture x86_64
Building initial module for 3.5.0-17-generic
Done.

fglrx_updates:
Running module version sanity check.
- Original module
- No original module exists within this kernel
- Installation
- Installing to /lib/modules/3.5.0-17-generic/updates/dkms/

depmod.......

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Setting up fglrx-amdcccle-updates (2:9.000-0ubuntu3) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-17-generic
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
---
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
DistroCodename: quantal
DistroRelease: Ubuntu 12.10
DistroVariant: ubuntu
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
NonfreeKernelModules: fglrx wl
Package: fglrx-installer (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Tags: quantal ubuntu
Uname: Linux 3.5.0-17-generic x86_64
UnreportableReason: Please work this issue through technical support channels first.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

 10/21/2012 02:26 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7246
Joined: 11/13/2009

This is a peer-to-peer user gaming forum. As such, the focus is on Windows OS...which is 99.9% used. You would be better served going to a open source forum for specific issues and/or use the AMD Issue report form >

http://www.amdsurveys.com/se.ashx?s=5A1E27D20B2F3EB8



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

Statistics
84985 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.