Topic Title: Unable to Update ATI 4570
Topic Summary: Dell Studio 1555 / ATI Mobility 4570
Created On: 10/25/2012 01:25 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/25/2012 01:25 PM
User is offline View Users Profile Print this message

Author Icon
mvpmakz
n00b

Posts: 2
Joined: 10/25/2012

Hello,

 

First time poster here looking for some advice!

 

Card in question is

 

Chip Type: ATI display adapter (0x9553)

DAC Type: Internal DAC(400MHz)

Adapter String: ATI Mobility Radeon HD 4570

Bios Information: BR32787-001

Dedicated Memory: 512

System Video Memory: 0

Shared System Memory: 1774

 

Recenlty I gave my Dell 15 to Dell's shop for full reinstall and diagnostics hardware/software check and had them install Windows 7 64bit.

 

When I received the laptop the driver it had was(and is at the moment) - 8.631.0.0 dated 25.6.2009, clearly out of date.

 

Before giving the laptop to the shop I used to have the 8.911(Catalyst 11.11) or 8.902(Catalyst 11.10), not sure exactly which. However, once I got my laptop back and tried to install the driver via the package downloaded from the official ATI site I could install the additional features, but not the Display Driver.

 

I tried both drivers, hell I tried TO INSTALL every single driver up to 12.6, and I couldn't see the Display driver listed in the Catalyst Installer. I tried using the Windows Update feature which is in the driver section of the card's properties in Windows, and it updated my driver to 8.97 which is not even listed on ATI's site. 

 

The issue is that when I run games with 8.631 or 8.97 I get an unexpected shutdown error which I am 95% sure is caused by the GPU driver. An error which was not there when I had 8.911 or 8.902. 

 

The error occurs the majority of time in World of Wacraft(even on lowest settings), and very rarely in Dota 2/SC2, almost never in Diablo 3.

 

So longstory short - I am looking for a way to install 8.911 or 8.902 to stabilize the system, but I can't because the packages from ATI's site say there is no Display Driver in them(I know sometimes they don't show it in the list of components when you have a higher updated version, but on the properties page it clearly says 8.631 driver version.

 10/26/2012 12:03 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7250
Joined: 11/13/2009

Here is a list of past Mobility drivers. 12.4 was the last Mobility update that included pre 5xxx cards/chips. Uninstall the current drivers using your computer 'uninstall a program'..express uninstall all AMD software. Reboot. Run driver fusion (free) http://treexy.com/products/driver-fusion  select AMD graphics and delete all it finds. Reboot. Install the new drivers. Reboot. You should be good to go.

http://notepad.patheticcockroach.com/1285/an-archive-of-amd-mobility-win-7-x64-drivers/



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 10/26/2012 09:08 PM
User is offline View Users Profile Print this message

Author Icon
mvpmakz
n00b

Posts: 2
Joined: 10/25/2012

Originally posted by: stumped Here is a list of past Mobility drivers. 12.4 was the last Mobility update that included pre 5xxx cards/chips. Uninstall the current drivers using your computer 'uninstall a program'..express uninstall all AMD software. Reboot. Run driver fusion (free) http://treexy.com/products/driver-fusion  select AMD graphics and delete all it finds. Reboot. Install the new drivers. Reboot. You should be good to go.

 

http://notepad.patheticcockroach.com/1285/an-archive-of-amd-mobility-win-7-x64-drivers/

 

 

I have very bad experience with using software like Driver Fusion. I think the previous one I used was DriverCleaner or something similar and I end up having nonstop bluescreens and reinstall Windows from a different source. 

 

 

Edit: Ok so I ran Driver fusion and when it was deleting files it said some files can't be deleted without Driver Fusion Premium. Is this ok? 

 

After the reboot I managed to install the driver and am currently using it. 

 

Two things that worry me - 

 

1) The device string says: "@oem3.inf,%amd9553.1%;ATI Mobility Radeon" - is this normal?

 

2) At the bottom right in the corner I have had "dead pixels" for a long time - they are dead "in the form of" showing the time, volume icon and half of the icon for internet connection. Could that in any way cause some failure in games as I can always see them even on Windows starting screen(where it says "Starting Windows")?

 10/26/2012 11:07 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7250
Joined: 11/13/2009

I am assuming you installed 12.4....now that you have that installed Win7 64 and this driver, go here and get the 12.6 beta. This is the latest update for your card > http://forums.guru3d.com/showthread.php?t=365426 .

Please be aware:

AMD Catalyst™ Driver for AMD Radeon™ HD 4000, HD 3000 and HD 2000 Series

AMD has moved  the AMD Radeon™ HD 4000, AMD Radeon HD 3000, and AMD Radeon HD 2000 Series to LEGACY driver support model. These updates will focus on resolving application specific issues and critical updates. The reason for the shift in support policy is largely due to the fact that the AMD Radeon HD 4000, AMD Radeon HD 3000, and AMD Radeon HD 2000 Series have been optimized to their maximum potential from a performance and feature perspective.

Applicable Products:

This article applies to the following configuration(s):

Hardware:

AMD Radeon HD 4000 Series
AMD Radeon HD 3000 Series
AMD Radeon HD 2000 Series
AMD Radeon HD Series AGP

The dead pixels won't affect the games...you will just have a dead spot there forever.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

Statistics
85569 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.