Topic Title: Solved: AMD Radeon 7600 on Windows 8 not being used
Topic Summary:
Created On: 11/18/2012 07:52 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/18/2012 07:52 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 11/18/2012

Hi all,

I just bought a new laptop and put Windows 8 on it. However, it seems that my GPU is not working. 

Graphics Card

AMD Radeon 7670 DDR3 1Gb

AMD Catalyst Driver Version, and Driver History
- current driver:

Operating System
- Windows 8 Pro x64 64-bit

Issue Details
I just bought a new laptop and put Windows 8 on it. However, it seems that my GPU is not working. There was a triangle with an exclamation mark in Device Manager. After some searching I managed to get it "fixed", trying drivers, catalyst controll center and Windows FixIt. However, I think this changed nothing, as it still is my CPU which handles all the graphics. I downloaded tools to see what my GPU was up to. FurMark says my GPU is constanty 0°, GPU-Z says it has aconstant GPU-load of 100%, and GPU Shark says 0.0%. So something is up...

-I first noticed this because I get lower-than-expected FPS in Counter-Strike: Global Offensive, even though I put all my graphics settings on low and I have a 1Gb GPU.

Motherboard or System Make & Model

Display Device(s) and Connection(s) Used
Built-in laptop screen

Applications and Games

- I have only been playing CS:Go so far
- include details about version or patch numbers

CPU Details
- Intel Core i5-3210M @ 2.50GHz, Clockspeed: 2.5 GHz, Turbo Speed: 3.1 GHz, No of Cores: 2

- No overclocking

Motherboard BIOS Version
- P04AAL, brand: I don’t know, Eureka if that is possible

System Memory Type & Amount
- 8Gb DDR3, I don’t not the brand because it’s not the standard memory, normally it’s 4Gb Sodimm, so perhaps 8Gb Sodimm

Additional Hardware
- none

Additional Details
- The system is new and has been checked for viruses and spyware 
- hardware shouldn’t be faulty as I bought the laptop a couple of days ago


Can someone please helpe me with this?


Edited: 11/21/2012 at 11:18 AM by Nizzl
 11/18/2012 10:32 AM
User is online View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8036
Joined: 11/13/2009

I don't know how you missed the LAPTOP forum? Several similar questions with answers there.


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 11/21/2012 11:15 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 11/18/2012


My GPU is now working, altho I still don't understand why. I was an idiot at first: I installed Catalyst, but because it made some adjustments of his own, I thought that was all there was to do.Eventually, I finally thought of opening up the CCC. It did recognize my grahics card, but the settings weren't maxed. I put them to performance, and suddenly my GPU-monitoring tool (GPU_Z) did find my graphics card, and gave the right load/temp/... values and better FPS in-game.

In conclusion: I do not know why all of a sudden the GPU-monitoring tool recognized the GPU (I did reïnstall the tool, maybe the earlier version was corrupt or not Windows 8 complient, which gave the wrong values) and how I got the GPU working, but after putting the performance of my GPU to performance, it was OK.

Only bummer: still not getting the FPS I would expect. Getting 60-100 now, where I would expect 150-200 (a friend of mine gets this FPS with a similar laptop, only his laptop is 3 years older. He has 0.03 Ghz more, but I have 4 Gb more RAM memory)

90252 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.