Topic Title: 7970m Skyrim - Texture Flickering [Resolved]
Topic Summary:
Created On: 11/27/2012 05:11 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/27/2012 05:11 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 11/27/2012

Hey all, switched over to AMD after a long time of Nivida, sometimes having issues with AMD products myself, but when it works, it be working well <3.

On the topic, on the latest drivers I tried (12.10 , 12,11 beta, new Enduro driver) I get these texture flickerings mostly on distant objects (skies, trees, mountains) it makes it unplayable for someone like me.

Official stuffz

Graphics Card

AMD Radeon 7970m - Running on a Clevo barebone (horay)

AMD Catalyst Driver Version, and Driver History

Running on 12.11b8 now

Tested skyrim on 12.11b8 only /12.10 and the new Enduro driver that came out this month with the dx9/10/11 compatibilty fixes.

Issue Details

Texture flickering (not seen while inside), tried all settings, setting AA/AF off and forcing them through CCC had no effect, changing AA type did not have any effect. Vsync on and off had no effect.

Trees flickering, distance mountains flickering, sky flickering. Trees seem to flicker between their normal color scheme and white.

[Deleted images for resizing]




Motherboard or System Make & Model

Clevo P170EM

Power Supply

CPU Details

Intel Core i7-3630QM CPU @ 2.40GHz

System Memory Type & Amount

16gigs of Ram 1600-Transcend

Additional Details

New system, Anti virus and Anti Malware installed, Regcleaner.

RAMTest came out clean.

Also see some texture clipping (z-fighting?) in the somewhat older assassin's creed games.

Any help would be appreciated, will launch a bug report if my problem doesnt seem to be system specific, and will try rolling back to older drivers.

Greets, and thanks in advance.

Edit: Tried rolling back to 12.8, alot of other amd users reported improvement on flickering, but my system appearantly is to new, so the driver doesnt work : / and fixed a typo, thats important, typo important, typo's will take over the world if we dont stop them, damn the typos.


Resolved: Installed the newest 12.11b11 that resolves image corruption on alot of titles and the 12.11cap2 profiles. This eliminated any corruption present, AMD, my hat of to you good sirs.







Edited: 12/03/2012 at 08:21 PM by Mozen
93358 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.