Topic Title: Trouble Updating Mobility Radeon HD 5000 Series Drivers
Topic Summary: Not given an option for display drivers on 13.1/13.3 Beta; Drivers not installing/working on 12.4
Created On: 04/11/2013 07:50 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/11/2013 07:50 PM
User is offline View Users Profile Print this message

Author Icon
amdUser28504
Peon

Posts: 3
Joined: 04/11/2013

I've been at this for two days, and it is frusterating me beyond belief.

I followed this guide, several times. Clean, reboot, clean, reboot, install, reboot. Nothing. It does not let me out of a stretched 1024x768 resolution, which is what I'm typing at now.

This is my exact system model: http://www.newegg.com/Product/Product.aspx?Item=N82E16834115855

I have tried multiple different driver suite versions:

  • 12-4_vista_win7_64_dd_ccc
  • catalyst_mobility_64-bit_util
  • 13-1_mobility_vista_win7_win8_64_dd_ccc_whql
  • 13-1_vista_win7_win8_64_dd_ccc_whql
  • AMD_Catalyst_13.3_Beta3

The last two do not include any options for display drivers. I am only given options for Catalyst Install Manager, AMD APP SDK, HDMI Audio, and VISION Engine Control Center.

Installing 12.4 (a rather old version) does give me display drivers, however they do not fix the problem. 13.1 Mobility gives the options as well, but the result is the same. Someone PLEASE help with this.

 

Also, I have another problem from when it did work. While on something that is not 12.4, I was not given any advanced graphic options in the CCC panel. Updating removes them for some crazy reason.

 04/11/2013 08:53 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6093
Joined: 11/13/2009

Have you done this?  http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162109&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

 04/11/2013 09:28 PM
User is offline View Users Profile Print this message

Author Icon
amdUser28504
Peon

Posts: 3
Joined: 04/11/2013

Originally posted by: stumped Have you done this?  http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162109&enterthread=y

 

I have now. Previously I had .NET 4.0.

Still the same. Stuck at 1024x768, with my display using 'Generic PnP Monitor on Standard VGA Graphics Adapter', and no option to change it.

Also, I do get this error when starting my system: http://i.imgur.com/xpnwgJo.png

 04/13/2013 10:01 AM
User is offline View Users Profile Print this message

Author Icon
shizukesa
Peon

Posts: 2
Joined: 04/13/2013

I'm having the same problem. Installing the driver after uninstalling Catalyst 12.8, installing .net v4.5 and rebooting doesn't change andything.

My specs are:

Graphics Card: ATI Mobility Radeon™ HD 5730 GPU

Driver History: Catalyst: 11.6, 12.1, 12.8

Operating System: Windows Home premium 7 64-bit

Issue Details:
When I was on catalyst 12.8, I would often 'install' the update, catalyst 13.1. After about 2 weeks, a window would pop up and tell me that I'm on catalyst 12.8 and need to update to 13.1 again. The same window popped up every couple of weeks, so I decided to uninstall my current 12.8 driver to install 13.1. I am now without an AMD driver, stuck on VGA default because my card will not detect any driver software although 'supposedly' I have catalyst 13.1 installed.

System Make & Model: Alienware M15x

CPU Details: Intel(R) Core i7 CPU 1.73GHz

 04/13/2013 10:16 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6093
Joined: 11/13/2009

Strange. I have no problem installing or using 13.1 or 13.3b3 on my Asus laptop HD5730 Mobility...or any of the previous drivers. I would suggest you go to your laptop manufacturer's support forum and see what other owners are saying.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

Statistics
81002 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.