Topic Title: Mobility Radeon HD 5470 Drivers not working
Topic Summary:
Created On: 05/18/2013 10:38 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/18/2013 10:38 AM
User is offline View Users Profile Print this message

Author Icon
lateralusderp
Peon

Posts: 3
Joined: 05/18/2013

I'm not quite sure where to start. There are multiple issue's I've encountered so far.

First, I can install the driver from my laptop's website, however it's from 2010. Upon downloading the latest from AMD's website (13.4), everything installs, however, the maximum resolution is 1024 x 768, and Aero does not seem to want to work. I moved on and tried the auto detect and install tool, only to find that it's under the impression that my laptop has a Mobility Radeon HD 4xxx Series, which it does not. 

I am running Windows 7 Ultimate 64 Bit. Here are my Laptop's specs under the "details" tab: http://www.newegg.com/Product/Product.aspx?Item=N82E16834115855

Prior to this most recent reformat on my laptop, I HAVE been able to install newer drivers with ease, and zero complications, so perhaps someone could direct me to some old, but still newer than 2010 drivers and I could try those out.

 05/18/2013 11:18 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7276
Joined: 11/13/2009

Reformat...do you have the required (look in 'How-to and FAQ section) netframework version? Have you checked windows update for 'suggested' downloads that don't install automatically? Have you used the clean install method > http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y 

Older Mobility drivers > http://benchmark3d.com/drivers-search

http://notepad.patheticcockroach.com/1285/an-archive-of-amd-mobility-win-7-x64-drivers/



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 05/18/2013 11:21 AM
User is offline View Users Profile Print this message

Author Icon
lateralusderp
Peon

Posts: 3
Joined: 05/18/2013

Yes, I do have all the required net frameworks. I literally just reformatted, and the issues posted in my original post are prevalent. I use the cleanup utility, to no avail. I will try the link you posted with older drivers and see what happens.

 05/18/2013 12:26 PM
User is offline View Users Profile Print this message

Author Icon
lateralusderp
Peon

Posts: 3
Joined: 05/18/2013

Picked one of the 12.x drivers. That one seems to work. After that, I tried 13.2 which did not work. I will try a vast majority of them, I'm guessing this is an issue on AMD's end..?

Simple question: Is the CCC completely necessary? 

 

EDIT: It seems that everything works just fine up until 12.10. Once I unstall 12.10, the issues in the original post arise.



Edited: 05/18/2013 at 01:07 PM by lateralusderp
 05/18/2013 02:38 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7276
Joined: 11/13/2009

 ""EDIT: It seems that everything works just fine up until 12.10. Once I unstall 12.10, the issues in the original post arise."" ...which is at the point where the Netframework requirement comes in to play. I would double check that..it should be version 4.5 plus the additional 3-4 updates from  Windows update. The 5470 is a very weak card not designed to play games with, so, no..you don't really need CCC if you don't need to adjust anything.

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

Statistics
86438 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.