Topic Title: Framerate problems after driver update (ATI Mobility Radeon HD 3470)
Topic Summary:
Created On: 07/16/2013 12:05 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/16/2013 12:05 PM
User is offline View Users Profile Print this message

Author Icon
Jasmine987
Peon

Posts: 3
Joined: 07/14/2013

Hello, everyone.

I own a laptop that I use for gaming and surfing the Internet on a daily basis, and although it's about 3-4 years old, it is capable of handling *most* modern games just fine.

Anyway, I have recently decided to update my graphics drivers, but, to my disappointment, I ended up finding myself unable to even play 1080p videos without experiencing horrible framerate drops.

The same rings true for games - for example, I used to be able to play Team Fortress 2 at medium settings (in DirectX 8.1 mode) and the game almost never stuttered below 60 fps.

I have tried downloading GPU-Z and MSI Afterburner and checking the clock speed of my video card therein, but the results I got were quite vague.

According to MSI Afterburner, there was no change in my clock speed (it was always at the maximum), but GPU-Z indicated otherwise (the clock speed was cut in half for some reason).

Downgrading to the previous installation of the drivers did not make any difference.

I would really appreciate it if you could help me out.

Thank you in advance.

 

EDIT: Here's some more info about my system in case you need it.

 

Laptop model: Acer Extensa 5630

Operating system: Windows Vista Home Premium SP1

Processor: Intel Core 2 Duo (2.5 GHz)

RAM: 4 GB

Video card: ATI Mobility Radeon HD 3470



Edited: 07/17/2013 at 03:29 AM by Jasmine987
 07/22/2013 06:20 AM
User is offline View Users Profile Print this message

Author Icon
Jasmine987
Peon

Posts: 3
Joined: 07/14/2013

Well, would anyone care to help me find the remedy to my issue?

 07/29/2013 12:56 PM
User is offline View Users Profile Print this message

Author Icon
Jasmine987
Peon

Posts: 3
Joined: 07/14/2013

Please?

Statistics
84905 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.