Topic Title: Newest non-beta drivers?
Topic Summary:
Created On: 08/10/2013 03:17 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/10/2013 03:17 PM
User is offline View Users Profile Print this message

Author Icon
aiat_gamer
Peon

Posts: 6
Joined: 04/06/2010

I have problems with 13.8 betaon my laptop, when I install it my brightness control stops working on the monitor. I wanted to install older version but seems like after 13.1 everything is in beta! Isnt there like a proper 13.7 for example?

 08/10/2013 03:24 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

You shouldn't use either of them. Go to the website of the manufacturer of the laptop, look up your machine, and get the drivers from the download section. That's what is supposed to work without issues. You see, laptop manufacturers customize the drivers for the specific machine. That's why the generic mobility drivers do not cut it.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 08/10/2013 03:31 PM
User is offline View Users Profile Print this message

Author Icon
aiat_gamer
Peon

Posts: 6
Joined: 04/06/2010

The latest drivers on their site for my laptop model is dated back to 2011!!!

 08/10/2013 04:59 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

Originally posted by: aiat_gamer The latest drivers on their site for my laptop model is dated back to 2011!!!

 

Then go back to what worked for you but is newer than that. Also contact their support  department and nag them for newer drivers.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84170 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.