Topic Title: AMD Radeon don't work
Topic Summary:
Created On: 09/19/2013 08:24 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/19/2013 08:24 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 4
Joined: 09/19/2013

I've recently bought a notebook HP ENVY m6, with an AMD Radeon HD 7670m graphic adapter.
Since the beginning I've noticed very poor performances on videogames.
Searching for a cause, I've noticed that programs uses the integrated Intel HD 4000 instead of the AMD one.

Searching further, I've noticed that even if both graphic adapter are correctly installed, Catalyst don't recognises the AMD one.

I've tried several solutions found on different forums, like update drivers or change the configuration of the switchable graphics, but nothing changed.

Is that a software or a hardware issue?

What could I do to fix it?


Thanks in advance

 09/19/2013 09:05 AM
User is offline View Users Profile Print this message

Author Icon
80 Column Mind

Posts: 13542
Joined: 04/17/2008

Talk to HP and ask them why your recently purchased HP notebook is not working correctly.

AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970 GHz Edition, 1TB Samsung 850 Evo, 256GB OCZ Vector, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ult Ed x64
 09/19/2013 09:30 AM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8773
Joined: 11/13/2009

It sounds like you tried to install drivers from AMD, which you cannot do. Read the sticky "updating mobility drivers" in the LAPTOP forum. Go to HP and get the drivers designed for your laptop. If you don't know how to operating your computer ask HP support or post in the HP laptop support forum for answers.


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

93161 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.