Topic Title: Frozen Brightness Win 8.1
Topic Summary:
Created On: 09/24/2013 03:47 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/24/2013 03:47 PM
User is offline View Users Profile Print this message

Author Icon
Dwdization
Peon

Posts: 2
Joined: 09/24/2013

Hi,

through the msdnaa program I have somehow upgraded my Lenovo G565 to the final Windows 8.1 and thus my problems began. I installed the latest driver and CCC from the AMD site but

- laptop brightness control doesn't work. The indication bar scrolls, but that's all

-when I go to Device Manager - Display adapters and select 'Roll back' in the AMD's Properties, the brightness works as supposed, but the driver is dead, screen resolution low and animations laggy.

-updating (unrolling back) disables my brightness and enables the driver again.

Any help? Thanks in advance, David

 09/25/2013 01:21 PM
User is offline View Users Profile Print this message

Author Icon
Shpati
Peon

Posts: 40
Joined: 10/01/2009

I read a lot of people are having this issue.



-------------------------
 09/25/2013 01:22 PM
User is offline View Users Profile Print this message

Author Icon
Shpati
Peon

Posts: 40
Joined: 10/01/2009

I read a lot of people are having this issue.



-------------------------
 09/25/2013 03:34 PM
User is offline View Users Profile Print this message

Author Icon
Dwdization
Peon

Posts: 2
Joined: 09/24/2013

Thanks

 11/02/2013 11:03 PM
User is offline View Users Profile Print this message

Author Icon
SahilC
Peon

Posts: 1
Joined: 11/02/2013

I'm having the same issue! Can anything be done?

Lenovo ideapad s405

 11/09/2013 09:42 PM
User is offline View Users Profile Print this message

Author Icon
johnbe
Peon

Posts: 2
Joined: 11/09/2013

For me this problem began when I installed Catalyst 13.4. I have an ASUS laptop with AMD E-450 APU (Radeon HD6310), the windows and the Asus brightness control moves left to right normally when pressing Fn+F5 or F6 but brightness does not change.

I rolled back to Catalyst 13.1 (the problem was not present previously with that version) but the problem persisted even after unistalling catalalyst 13.4 before installing 13.1 again. The only way to restore brightness control functionallity was removing the device driver from the device manager and letting windows install the default driver for my APU.

We now have Catalyst 13.9 and the problem have not been fixed yet. Nothing have been heard from AMD about it.

 11/11/2013 06:49 AM
User is offline View Users Profile Print this message

Author Icon
djpimpek
Peon

Posts: 1
Joined: 11/11/2013

Windows 7 64bit, Mobility Radeon HD 5470 - after install Catalyst 13.9 = no brightness... Repair this AMD team...

 11/14/2013 08:53 AM
User is offline View Users Profile Print this message

Author Icon
Karaçam
Peon

Posts: 2
Joined: 10/21/2013

I'm having the same issue! Sony vaio YB series laptop with AMD E350 APU. 
Too many people suffer for this problem 

 11/20/2013 09:06 PM
User is offline View Users Profile Print this message

Author Icon
johnbe
Peon

Posts: 2
Joined: 11/09/2013

This is very frustrating, no word from AMD. It seems no one from the support team reads these forums.

I think the problem was introduced in Catalyst 13.4, but now more people is having it because Windows 8.1 updates de driver to 13.9 version, I cant roll back to 13.1 now.

 03/08/2014 03:19 PM
User is offline View Users Profile Print this message

Author Icon
hpEnvy15
Peon

Posts: 3
Joined: 03/08/2014

I'm having the same problem with a clean install of Windows 8.1 and the latest Catalyst drivers. Brightness controls stop working.

 

HP Envy 15 model 1150nr laptop

Mobility Radeon 5830 graphics

 

Here's what is happening for me. Windows initially installs the " Microsoft basic Display Adapter" driver. With this driver, the brightness controls work fine, whether it's being changed from the kepboard function keys, from the Power Options screen, or from the Windows 8.1 settings menu (Win + I).

As soon as the driver is updated to the lastest Catalyst version, brightness controls stop working completely. I've tried every proposed solution found online to no avail.

Also tried using the latest beta version of Catalyst. Still doesn't work. I have updated all necessary drivers, including Intel chipset motherboard drivers. 

When the latest Catalyst drivers are installed, brigtness controls just don't work. Reverting back to the MS basic display adapter fixes the issue immediately (without rebooting even), but is not an optimal driver for performance, so it's not really a good option.

Can anyone help? Thanks in advance!

Statistics
86417 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.