Topic Title: Black screen after installing drivers
Topic Summary: hdmi works fine laptop screen goes very dark
Created On: 10/01/2013 12:58 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/01/2013 12:58 PM
User is offline View Users Profile Print this message

Author Icon
maorgit
Peon

Posts: 2
Joined: 10/01/2013

i have a asus x54h laptop with radeon hd 6470m. windows does not find the drivers (i just clean installed windows 7) and after installing catalyst beta 13.10 or any other catalyst windows loads up fine(starting windows screen) and than dims so dark its barely notisable that screen is not black. i have been trying to fix this for 3 days please help me

 10/01/2013 01:19 PM
User is offline View Users Profile Print this message

Author Icon
Fishman
Master Looter

Posts: 332
Joined: 10/14/2011

Try the video drivers from Asus for your laptop.



-------------------------

GA-MA-790FXT-UD5P/ AMD Phenom II X4 965 Black/2 x XFX HD5870 /RipjawsX 2x4gb DDR3 1333/ Corsair TX750M/ Antec 900 case/ Windows 7x64 Ult.


 

 10/01/2013 01:26 PM
User is offline View Users Profile Print this message

Author Icon
maorgit
Peon

Posts: 2
Joined: 10/01/2013

thanks for the advice but i have tried that as well with no success ... when i try to install the VGA drivers from my laptop drivers page i cant i get a wierd message that my computer doesnt match the minimum requierments for that driver 

Statistics
85713 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.