Topic Title: AMD Catalyst Center not working
Topic Summary:
Created On: 10/19/2013 11:14 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/19/2013 11:14 AM
User is offline View Users Profile Print this message

Author Icon
Th3Assasinat0R
Peon

Posts: 4
Joined: 10/19/2013

 

Laptop System Specs :

OS- Win 8.1 64 bit
Processor : i7 3632QM
Card : 7670M 
Ram : 8gb
I tried downloading from here : http://support.amd.com/en-us/download

I entered 
notebook graphics > Radeon HD Series > Radeon HD 7xxxM Series > Windows 8.1 64-bit
(I a 64 bit OS and 7670M card in my laptop)
Then I arrived here,
I downloaded and installed the beta driver (235 mb) and it made things worse. I got the same message that I had earlier and when I checked my device manager, both my cards (intel hd 4000 & amd 7670m) showed problems. I rebooted my laptop and got a message at startup saying no graphic drivers were detected. I then went to the device manager and did a driver rollback. I'm back to square one now.
My DxDiag report incase you need it : 
 10/19/2013 11:58 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7250
Joined: 11/13/2009

Laptop forum

http://forums.amd.com/game/categories.cfm?catid=448&flcache=2172653&entercat=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 10/19/2013 02:38 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

There's a bug in the 8.1 update, it broke CCC for everyone. Just look at the threads...

If your laptop OEM already supports 8.1, reinstall 8.1 (clean) and install OEM drivers.

If the OEM has no 8.1 drivers, then install 8 vanilla (or 7) and stick to it until the OEM releases proper drivers.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 10/19/2013 03:09 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Try the mobiity driver for 13.11 beta located here.

http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

Statistics
85504 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.