Topic Title: Video Card dissappeared on device manager after uninstalling CCC.
Topic Summary:
Created On: 10/24/2013 04:06 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/24/2013 04:06 PM
User is offline View Users Profile Print this message

Author Icon
darkhamdi
Peon

Posts: 1
Joined: 10/24/2013

Hello Guys, i have ATI Mobility Radeon HD5650 with Toshiba Satellite L670 and im in a big trouble here. My CCC was old, so i decided to update it. When i tried to update, it failed saying "package error" so i re-downloaded the file but this time before updating i decided to uninstall my old ccc. When i uninstalled it, it also deleted the display driver with it and then my monitor resolution came down to 800x600. I checked it, on display manager it says "Simple VGA Display". My HD 5650 does not seem there, and i can not get it back because when i try to install ccc it says no amd device found. Please help me guys, i will be more than appreciated.

 10/25/2013 12:36 PM
User is offline View Users Profile Print this message

Author Icon
moneyistime44
Peon

Posts: 12
Joined: 10/24/2013

i did a search on this site   http://driverscollection.com/?   and may have found compatible software for your device.  go there and click search then into the simple search bar enter  Mobility Radeon HD 5650 (the name of YOUR hardware) and search, look through them and download the version for your system etc.  this should also update your catalyst control center. i hope this helps.

 10/25/2013 12:46 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7426
Joined: 11/13/2009

For CCC to function with the newer drivers, you must have at least the netframework 4.5 installed. Have you checked Windows Update for 'optional' updates lately?

FAQ section

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162109&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

Statistics
87482 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.