Topic Title: AMD VISION Engine Control Center crashed
Topic Summary: Crashed while playing Battlefield 4
Created On: 10/24/2013 10:58 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/24/2013 10:58 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 10/24/2013

So when the open beta for Battlefield 4 game out earlier this month I was super excited to try it even though I knew my laptop probably wouldn't be able to handle it. However I did it anyway and the first thing I did in the VISION control center was to set Battlefield 4 to high performance in order to switch to my dedicated graphics cards (which is how I think you are suppose switch to the dedidcated GPU, I'm still not 100% that's how you do it).

My laptop has a AMD A10-4600M APU w/ Radeon HD 7660G graphics along with a Radeon HD 7730M dedicated GPU. Changing it to high performance didn't really help out too much even at low game settings which prompted me to began configuring the GPU.

So there I was tweaking with the VISION control center to improve the performance of the game, after finishing a few changes I started the game up again and BAM, I got a message saying the VISION Engine Control Center has stopped working. Naturally I started to google how to fix my issue and tried many possible solutions until I eventually just uninstalled the AMD VISION Engine Control Center software. Next, I downloaded the new Catalyst Control Center suite as well as the latest Microsoft.NET framework. 

The good news is that the program actually opens, the bad news was is it doesn't display any options for configuring my GPU. All it really shows was my CPU speed. 

The problem I think is that the Catalyst Control Center program wont let me configure my GPU b/c it might not be the same as the AMD VISION Engine Control Center, which was designed for computers which use a AMD CPU and GPU. My second thought is that there is a problem with the GPU itself.

What do you guys think?


 10/25/2013 12:44 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 12
Joined: 10/24/2013

i experienced something similar to this as one day i opened the control engine and all my settings were gone except for the cpu, and power options. i went here   and searched for my card and downloaded the appropriate soft ware and all my tabs returned in the control engine. i hope this works for you aswell.

93107 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.