Topic Title: AMD 'Displays do not support audio' message in Vision Control Centre - Windows 8
Topic Summary: My headset will not play audio on video playback, only for communications.
Created On: 10/27/2013 09:34 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/27/2013 09:34 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 10/27/2013

Hi Guys!

Ive just purchased the HP Pavillion  15 - n083ea . Running Windows 8.

Last night i tested my headset via Skype to check that it configured and worked okay - everything seemed fine!

This morning i tried to go on youtube and to watch other videos/ listen to other music online (on various sites) and no audio would play through my headset.

Ive essentially raped google & tried all the usual fixes and checked all the audio settings and everything seems to be fine, but alas - it still doesnt work for playback!

In the AMD Vision Engine control centre i am getting a message which says 'Your displays do not support audio'. It asks me to select another device from the list (I have the choice of my HP Speakers or Logitech headset) but this doesnt seem to make a difference regardless of which one i selct- its like nothing happens/ changes.


The headset im using is a USB one, normal headphones (using a jack connection) seem to play audio okay but it just will not play through my headset.

Im really hoping there is a quick fix for this, however after hours or trawling google i cant seem t fiind one!

If anyone can help i'd be crazy greatful, and if theres and info you need i havent included please ask - im not really sure what is needed to diagnose the issue!


Thanks guys, hopefully one of you can help!

Meesh x




93412 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.