Topic Title: AMD Catalyst 64-bit windows 8 "This APP can't run on this PC"
Topic Summary: AMD Catalyst 64-bit windows 8 "This APP can't run on this PC"
Created On: 11/03/2013 02:17 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/03/2013 02:17 AM
User is offline View Users Profile Print this message

Author Icon
MrPros
Peon

Posts: 1
Joined: 11/03/2013

When i'm trying to install the mobility catalyst on the amd website(with the correct information set) I want to download the new beta version so I can get a performance boost thats 13.11 beta 8 64-bit. I also tried to download 13.11 beta 7 64-bit also but it wouldn't work. When I try to run it everytime it keeps saying "This APP can't run on this PC. To find a version for your PC, check with the software publisher." I currently have AMD Catalyst 13.10 beta from the AMD website. I tried to update my .NET framework, change compatibilities, changed browsers, restarted, and run as administrator. None of those worked for me so I hope you guys can help me I have an MSI laptop(MSI 1AC-021US)

CPU: A10-4600M quad-core + Radeon 7660G

GPU: AMD Radeon 7970m

OS: Windows 8 Premium 64-bit

Statistics
83899 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.