Topic Title: [SOLVED] Can't install AMD Catalyst Mobility, "Application Install: install package failure" error
Topic Summary:
Created On: 11/10/2013 12:38 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/10/2013 12:38 PM
User is offline View Users Profile Print this message

Author Icon
ksio89
Peon

Posts: 4
Joined: 11/10/2013

After a clean install of Windows 8.1 Pro x64, I installed the Intel HD Graphics drivers and then attempted to install the Catalyst Mobility provided by Dell for my notebook model, which is an Inspiron 15R-5537 with a Radeon HD 8850M GDDR5, but the following error message appears:

"Application Install: install package failure"

I tried installing the latest official AMD Catalyst Mobility (13.11 beta 9.2) package, but get the same error. How can I solve this? Thanks in advance.

Info:

Notebook model: Dell Inspiron 15R-5537

OS: Windows 8.1 Pro x64 PT-BR

CPU: Intel core i5-4200U

GPU: AMD Radeon HD 8850M GDDR5

 

Screenshot:

 

 



Edited: 11/13/2013 at 09:15 PM by ksio89
 11/10/2013 04:55 PM
User is offline View Users Profile Print this message

Author Icon
boodaddy
Peon

Posts: 2
Joined: 11/10/2013

I get the same exact message. I downloaded the latest driver from AMD. Can't get around the error. Any advice or help would be much appreciated. 

Laptop Model: Asus K72JK

OS: Windows 7 Ultimate x64 Bit

CPU: Intel Core I5

GPU: ATI Mobility Radeon HD 5145 1GB

 11/10/2013 07:30 PM
User is offline View Users Profile Print this message

Author Icon
ksio89
Peon

Posts: 4
Joined: 11/10/2013

Hey mate, I fixed it by installing Visual C++ 2012 runtime Update 3 (google them, it's the first result) redistributables, both x86 and x64 versions. I installed VC++ 2010 SP1 redistributables as well, both x86 and x64. 

After doing this, I tried installing the Catalyst package provided by the laptop manufacturer, and this time it worked fine. I believe the official one from AMD driver page will work as well.

After installing Catalyst drivers, reboot and it should work now, check the context menu in desktop, 2 new graphic options should appear.

Try doing that and reply me if this worked or not. Good luck.

 11/11/2013 04:52 PM
User is offline View Users Profile Print this message

Author Icon
boodaddy
Peon

Posts: 2
Joined: 11/10/2013

Originally posted by: ksio89 Hey mate, I fixed it by installing Visual C++ 2012 runtime Update 3 (google them, it's the first result) redistributables, both x86 and x64 versions. I installed VC++ 2010 SP1 redistributables as well, both x86 and x64. 

 

After doing this, I tried installing the Catalyst package provided by the laptop manufacturer, and this time it worked fine. I believe the official one from AMD driver page will work as well.

 

After installing Catalyst drivers, reboot and it should work now, check the context menu in desktop, 2 new graphic options should appear.

 

Try doing that and reply me if this worked or not. Good luck.

 

 

You rock man! That totally fixed the issue. They should sticky this for the solution. Thanks so much for taking the time to reply with the fix. YOU ROCK!

 11/13/2013 02:13 PM
User is offline View Users Profile Print this message

Author Icon
ksio89
Peon

Posts: 4
Joined: 11/10/2013

You're welcome, mate. Glad it worked for you too . After installing both Visual C++ 2012 packages, I uninstalled the Catalyst package provided by my laptop manufaturer and installed the latest official drivers from AMD, it worked like a charm as I supposed.   

 12/24/2013 02:14 PM
User is offline View Users Profile Print this message

Author Icon
ArnoldZiffel
Peon

Posts: 1
Joined: 12/24/2013

You are the man!  Actually installed the latest (update 4).  I never would have figured this out.  Win 7 64 bit.  Thank you very much.

 01/27/2014 09:12 PM
User is offline View Users Profile Print this message

Author Icon
Drano
Peon

Posts: 1
Joined: 01/27/2014

Tried this tonight after wrestling with the same problem and it worked like a champ! Thanks much ksio89!

 08/02/2014 05:19 PM
User is offline View Users Profile Print this message

Author Icon
vhcandido
Peon

Posts: 1
Joined: 08/02/2014

Just made my account here to thank you because your solution is still working just fine

Thanks!

 08/02/2014 06:11 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Good info here. Thanks for sharing



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84676 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.