Topic Title: Backlight issue
Topic Summary: Backlight display on laptop is turned off after installing 13.5 or newer
Created On: 12/13/2013 07:43 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/13/2013 07:43 AM
User is offline View Users Profile Print this message

Author Icon
Arbiter
Peon

Posts: 6
Joined: 12/13/2013

Hi,

I have a notebook from asus N71ja with Mobility Radeon 5730. I'm currently running cata 13.4, because it's the only one that actually works and doesn't make backlight of display go black, which occurs if I try to install 13.5 beta drivers or newer (including proper 13.9 version). Display itself works since I'm able to see what's on it using flashlight for example, but backlight simply doesn't work (and it's not brightness problem for sure). There are many topics on the internet about this but they're coming with only one anwser - stick to 13.4. 

I found it strange that AMD is not capable of dealing with it after more then half a year and would for once like to hear some official statement a hopefully resolution in 13.12 (or whatever version is coming up next). Thank you.¨

Zdenek Vesely

 12/13/2013 10:39 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

Ok....the question is, why am I having no problem (backlight or other)  with my Asus laptop?  See the model below. I am using the 13.9 whql. Have you sent a issue report to AMD?

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/13/2013 11:05 AM
User is offline View Users Profile Print this message

Author Icon
Arbiter
Peon

Posts: 6
Joined: 12/13/2013

Don't know, maybe config of Q model has something to do with it. Thing is that I tried everything from cleaning system of any drivers with driver fusion, even tried to install drivers on clean system after format. 13.5 or newer just turns backlight during installation of drives (in exact moment when in setup wizard shows Installing drivers or something like that) and don't come back. Safe mode works, so i can uninstall it or rollback to 13.4 which works for some reason. 

Basically this thread summs up everything I know about the problem and solutions I tried:

http://forums.guru3d.com/showthread.php?t=381583&page=3

 12/13/2013 11:30 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

There is a difference in the processor, I5 vs I7 , as far as I can see..but, one review of your model refers to a on-board Intel graphics. Do you have dual or switchable graphics? I am sure you have checked with Asus for any driver or bios updates, but have you been to Intel and run their "driver auto-detect" thing? This is puzzling.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/13/2013 11:38 AM
User is offline View Users Profile Print this message

Author Icon
Arbiter
Peon

Posts: 6
Joined: 12/13/2013

Not that I know of. That intel driver utility didn't find any, only Radeon model, device manager is also showing only one.

 12/13/2013 12:04 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

Are you using the 'auto-detect and install' program to install your drivers? I use the drivers from here and never use the Mobility drivers. The desktop version installs perfect...give it a try.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/13/2013 12:45 PM
User is offline View Users Profile Print this message

Author Icon
Arbiter
Peon

Posts: 6
Joined: 12/13/2013

Tried those, installation didn't finish (or it does but like in 2seconds with some report about some warnings) with link to xml report without any error messages (it is in Czech, but I guess the numbers are what shows what went wrong -if something did):

Správce instalace Catalyst™
Zpráva o instalaci
12/13/13 18:36:31

Informace o hardwaru
 
Název AMD Radeon Graphics Processor
Výrobce Advanced Micro Devices, Inc.
ID za?ízení 0x68c0
ID dodavatele 0x1002
Kód t?ídy 0x030000
ID revize 0x00
ID subsystému 0x1c22
ID dodavatele subsystému 0x1043
Jiný hardware
Existující balí?ky
Správce instalace aplikace AMD Catalyst (setup manager?)
Grafický ovlada? AMD (display driver)
Ovlada? pro zvukové za?ízení HDMI (sound device)
AMD Accelerated Video Transcoding
Nástroj AMD pro konverzi videí p?etažením (conversion utility)
Kódova?e AMD Media Foundation
Catalyst Control Center
Balí?ky pro instalaci
Správce instalace aplikace AMD Catalyst
Kone?ný stav: Úsp?ch (success)
Verze položky: 8.0.915.0
Velikost: 20 MB
Ovlada? pro zvukové za?ízení HDMI
Kone?ný stav: Úsp?ch (success)
Verze položky: 7.12.0.7716
Velikost: 1 MB

Jiná detekovaná za?ízení
 
Výrobce Advanced Micro Devices, Inc.
ID za?ízení 0xaa60
ID dodavatele 0x1002
Kód t?ídy 0x040300
ID revize 0x00
ID subsystému 0xaa60
ID dodavatele subsystému 0x1043


Chybové zprávy (error messages - nothing below this)

 

CCC is still showing 13.4

 12/13/2013 01:14 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

The FAQ section has a post 'installing/uninstalling' drivers. Part 2 might help.

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/13/2013 01:39 PM
User is offline View Users Profile Print this message

Author Icon
Arbiter
Peon

Posts: 6
Joined: 12/13/2013

Uninstall part: Done that before in combination with Driver Fusion.

Install part: Mobility Radeon Driver Verification never said anything about my card not beign compatible. Mobility Drivers either install completely without a hitch (in which case the backlight turns of after restart) or turns of backlight during installation but proceed, do not interrupt itself by doing so. Dekstop drivers cancel right after the start of the installation, but I don't think that prove something about incompatibility, since they are after all for desktop, not mobility card, even though it works for you.

Thanks anyway. For your time and ideas. I'll hope it will be fixed in some later drivers, or some of the users on phorum mentioned before will find solution to this.

 12/13/2013 01:54 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

Did you try Part 2??

Part 2
The following additional steps are recommended to advanced users, and only if the Catalyst Driver installation was not successful after attempting the uninstall steps provided in Part 1.

  • After completing the uninstall steps provided in Part 1, restart the system into Safe-Mode.
  • Log in as the Administrator.
  • Navigate to the folder, "C:\Windows\assembly"
  • Sort the entries by, "Public Key Token"
  • Locate entries with the public key token, "90ba9c70f846762e"
  • Delete or uninstall (by right-clicking) all entries associated with that public key token only.
  • Restart the computer into Normal-Mode.


-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 12/13/2013 02:11 PM
User is offline View Users Profile Print this message

Author Icon
Arbiter
Peon

Posts: 6
Joined: 12/13/2013

It's not there if I use Driver Fusion as uninstaller so I guess that takes care of it in process. Then if I boot up in normal mode and try to install drivers again, mobility drivers make screen black, desktop drivers finish installation prematurely and throw back report I posted above. And, of course, 13.4 works again with no problem afterwards.



Edited: 12/13/2013 at 04:04 PM by Arbiter
Statistics
84172 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.