Topic Title: Latest AMD Mobility Drivers Break Older Games (MW4 Mercs and Falcon 4.0)
Topic Summary:
Created On: 12/30/2013 01:24 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/30/2013 01:24 AM
User is offline View Users Profile Print this message

Author Icon
TheHolyLancer
Peon

Posts: 1
Joined: 12/30/2013

I have a xotipic np7180, or clevo P170EM

So the tale begin a few months ago, I had been using bascially the Clevo supplied driver from Jan 2013 (no idea which version of the driver it is...) since at the time the normal stuff didn't really install on this laptop as it won't reconize the card as a valid AMD card.

That worked with everything, from old games to new. But the performance on the newer titles were something of to be desired... I had just gotten Payday 2 and it was running like a dog, so I thought I'd give the AMD drivers a try since Clevo didn't had a package for me.

I tried the offcial one (13.7?), but then that didn't really work, then I tried 13.8beta2 and that actually installed automatically (yay). Worked wonders with PD2 and increased performance in bioshock infinite too!

I was happy, and know that likely I won't need to rely on Clevo or extracting raw drivers again to update this thing.

But then, when I tried to launch MW4 Mercs (the free version from MTX), I noticed that the menu became distored and I can't realy do anything...

See: http://i.imgur.com/FBbIBSH.png

And then in Falcon 4.0, the plane isn't rendered correctly...

I thought, oh well this is the beta, let me just wait a bit for a full release.

Given I had it working with the old drivers, and modern games (pd2, bio inf, bf4 now, eve online, lol) all work, likely means it isn't a dying card, or if it is then a weird death...

And promptly forgotten about it until 13.9 came out. I updated to that via the autoupdate (sweet). And This issue persisted.

I just updated to 13.12 to improve BF4 performance, which did do so BTW thanks, but the MW4 and Falcon 4.0 remains broken...

 

Anyone know of a workaround other than roll back... Or build a "retro" rig (not exactly retro these games... they don't even need voodoo and glide to run god damn it)

 12/30/2013 03:47 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7030
Joined: 11/13/2009

Have you tried running the game in compatibility mode...maybe XP?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84141 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.