Topic Title: Samsung switchable graphics issues
Topic Summary: Samsung series 3 switchable graphics - AMD card performance drop
Created On: 02/17/2014 11:38 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/17/2014 11:38 AM
User is offline View Users Profile Print this message

Author Icon
szfamman
Peon

Posts: 2
Joined: 02/17/2014

Hi everyone!

I have a Samsung Series 3 NP370R5E-S01 laptop.
I played with several games. 

  • Battlefield 3 :~50-60 fps
  • DayZ: ~30-35 fps),
  • World of Warcraft :45-60 fps




Yesterday i rebooted my laptop (usually i just hibernate it, thus the system setup time is always big for me).
Now comes the interesting part: all of these games lost half of the fps:

  • Battlefield 3 :~20-30 fps
  • DayZ: ~10-20 fps),
  • World of Warcraft: ~20-35 fps



What happened? The installed amd driver was 13.6 Mobility Beta2. I tried to reinstall the driver, but nothing. I tried several other drivers: 14.1 Mobility BetaV1.6, 13.12 Mobility WHQL, but nothing.

I opened up GPU-Z and checked the card. Now it is recognised as "AMD Radeon HD 8600/8700M". Last time it was clearly "AMD Radeon HD 8750M".
And i noticed somthing about the pixel fillrate. Now the maximum is only 3.3 GPixel/s. It used to be >6GPixel/s.
The Texture fillrate changed as well. It was like 19 GTexel/s, now it's only 6.6 GTexel/s.


UPDATE: I installed the 12.102 version driver (this is the stock one. it can be downloaded via Samsung SWUpdate). The pixel and texture fillrate was "good" again (pixel: 6.6GPixel/s, texture: 19.8 GTexel/s), but the games' performance was the same (for example WoW: now 25 fps; it should be 45-50).
Now i have leshcat's 13.8_Beta_1_UnifL, but it's the same as the 12.102.

Please help me guys to get back the former performance!
Thanks,
Tom

 02/21/2014 09:00 PM
User is offline View Users Profile Print this message

Author Icon
szfamman
Peon

Posts: 2
Joined: 02/17/2014

No one has this issue, only me?

 02/26/2014 01:46 PM
User is offline View Users Profile Print this message

Author Icon
k1ll3runa
Peon

Posts: 9
Joined: 12/05/2013

I'd suggest chechking the power saving settings.



-------------------------

AMD HD 8670M Owner

 03/28/2014 01:15 PM
User is offline View Users Profile Print this message

Author Icon
AleighS
Peon

Posts: 2
Joined: 03/28/2014

I have a samsung laptop with a radeon 8700m card as well as intel hd graphics.

I have had a mountain of issues with this. Applications and games often only want to detect the intel card. I have tried updating the graphics card multiple times, but the amd site cannot even detect a compatible card, the samsung software update utility allowed me to update, but even the catalyst control center only allows me to see the intel card.

The odd thing is, I can still play some games great, most recently was bioshock infinite at medium settings and 1080 with no lag except a slight second when traveling between areas.

Deus Ex though has randomly run perfect some runs and then crappy the next time I play. Alan Wake is impossible to get running on even the lowest settings above 5-10fps, and resident evil 6 I immediately get a black screen and the game stops responding.

I feel that most of these issues have to do with some combination of the graphics and windows 8 personally. I had an older samsung laptop with windows 7 and a less powerful gpu and could run every one of those games listed med-high settings just fine.

sorry I cannot help you yet, but I wanted to share the similar issues I have had trying to figure out who to get my games running properly and consistently. I will be sure to share my progress if I manage to make any.

 03/28/2014 01:59 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

UPDATING MOBILITY DRIVERS

Notice the part about 'switchable graphics?

Either use the manufacturers supplied drivers or the Leshcat drivers.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *



Edited: 03/28/2014 at 02:27 PM by stumped
Statistics
84170 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.