Topic Title: 6970M ATI Laptop Backlight Dim
Topic Summary: Updated to new A12 BIOS, PEG setting, Updating drivers, screen dims.
Created On: 02/23/2014 08:13 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/23/2014 08:13 PM
User is offline View Users Profile Print this message

Author Icon
Isolace
Peon

Posts: 1
Joined: 02/23/2014

I recently updated my M17X-R3 6970m BIOS from stock to the newset version (off Dells website) A12.  I was doing in this in hopes to finally update the ancient drivers for my 6970m GPU. (using the SG/PEG option).

Everything started smooth on the PEG, I was able to initially update to the 13.12 drivers and games just ran so much smoother!  After a while of playing I noticed that there was a difference in the intensity from my main external monitor, to my laptop screen.  This was never the case in the past, so I figured that I had to mess with some of the power settings, as it looked very similar to how it would look when I was unplugged and the screen would dim to around 60-40%.  After hours of searching down this path I started to wonder if it was the drivers.  So I did a clean uninstall, swept, and reinstalled clean.  This is when I noticed something strange.  After the clean install, the computer booted to my log in screen, I passcoded in, the screen was bright!! much excite...but then about 2 seconds after I logged in, the screen went to the "dim" look.  So I restarted hoping that would fix it, and now it is just always dim.  I am coming to you guys because I am out of options.  I have tried (clean uninstalls, sweeps) 13.4, 13.12, 13.9...all the same.



Edited: 02/23/2014 at 08:25 PM by Isolace
Statistics
89039 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.