Topic Title: Display goes black after updating the latest (13-12) drivers to a Mobility Radeon HD5730
Topic Summary: Driver update failure black screen Radeon 5730
Created On: 03/03/2014 06:28 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/03/2014 06:28 PM
User is offline View Users Profile Print this message

Author Icon
alpha1983
Peon

Posts: 1
Joined: 03/03/2014

After updating the ATI drivers of my computer, an Asus N61jq to the latest version I found that the screen went dead after displaying the windows logo.

Launching the safe version and checking the device manager shows that the name of the card has changed from ATI Mobility Radeon HD 5730 to 6700/5700.

I´ve tried to uninstall all ATI software until the driver installer couldn´t find any elements in the machine and then I reinstalled the drivers, but I allways get the same result.

So far I got back some old drivers (version 8.692.1.0) by performing a rollback, but the previous version I had installed (13-1_mobility_vista_win7_win8_64_dd_ccc_whql.exe) is lost.

Any ideas of why this could be happening and how can I solve it?

Thanks in advance

 03/03/2014 07:16 PM
User is offline View Users Profile Print this message

Author Icon
FiJaY5050
Peon

Posts: 2
Joined: 03/03/2014

I am having the same problems with the same laptop.

 

I have to use system restore to rollback and get things to work.  HDMI Output works but laptop screen is black.  (I can kind of see things on the black screen)

Looking forward to a solution so I can enjoy the latest updates

 03/03/2014 07:16 PM
User is offline View Users Profile Print this message

Author Icon
FiJaY5050
Peon

Posts: 2
Joined: 03/03/2014

Also the installation was working but stopped working after a restart

 03/03/2014 08:12 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7225
Joined: 11/13/2009

Asus laptops and any driver version past 13.4 do not play well. Lots of posts here about it. Mainly the blackscreen. You can hook the laptop up to a external display and it works fine...just the laptop screen is affected. If you were trying to install either of the new Beta drivers, you must completely uninstall your current drivers first.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

Statistics
84881 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.