Topic Title: HD 8530M + Intel HD4400 switchable driver issues
Topic Summary:
Created On: 03/12/2014 09:10 AM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/12/2014 09:10 AM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

Hello!

I've bought Asus S301LP (http://www.asus.com/Notebooks_Ultrabooks/ASUS_VivoBook_S301LP/).

After upgrading from Windows 8 to Windows 8.1 Amd Catalyst Control Center can't detect my videocard:

 

I've tried clean Windows 8.1 install:

1. Chipset driver from Asus site

2. Intel video driver from Asus site

3. AMD video driver  from Asus site

Same problem.

Next i've tried to install Intel drivers from Intel website & beta driver from AMD site.

Now i can launch CCC but my laptop is not turning off (lcd is black but notebook is still working).

To turn off my PC i need to disable videocard in device manager.

 

Any solution? Thank you.

 

 

 03/23/2014 03:24 PM
User is offline View Users Profile Print this message

Author Icon
stlauren
Peon

Posts: 3
Joined: 03/23/2014

I have the same issue. I try to deactivate HD 4400. But windows 8.1 desactivate also HD8530M and start with generic driver.

Is somewhere else have the same problem ?

 03/23/2014 03:27 PM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

I've fixed the issue:

1. Install ALL updates from Windows Update on Windows 8.1

2. Check for Windows Updates again and install missing

3. Reinstall driver for HD8530M from Asus website

 03/24/2014 05:54 PM
User is offline View Users Profile Print this message

Author Icon
stlauren
Peon

Posts: 3
Joined: 03/23/2014

I tried your procedure. Don't work on my PC: always the same warning windows.

several questions:

- which intel driver version do you installed (3308 or 3355 ?) from asus download site?

- do you install intel driver first, then amd driver or vice versa?

- do you remove all amd components before install the last driver?

thank you in advance for your help...

 

 

 03/25/2014 03:12 AM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

Intel HD driver: 10.18.10.3355

Try this:

1. Uninstall AMD driver

3. Install ALL windows updates

4. Install Amd driver from Asus (link above)

 

I've Asus chipset installed too (prior everything).

 03/26/2014 10:54 AM
User is offline View Users Profile Print this message

Author Icon
stlauren
Peon

Posts: 3
Joined: 03/23/2014

I try many configuration of installation. None works.

Either the CCC works with more recent drivers for HD8530M card, but will a big issue for computer wake-up (don't work), or the wake-up is OK, but not the CCC.

I believe it is an AMD issue when working in dual graphic configuration. It seems the issue is solve in recent upgrades, but not encapsuled by ASUS team for S301LP computer...

 

 03/26/2014 02:27 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Use the Leshcat drivers. Google



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 03/26/2014 05:08 PM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

Leshcat drivers won't help.

 03/26/2014 06:56 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Originally posted by: Romanov Leshcat drivers won't help.

why? Is there something else you have done to your computer that your not mentioning?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 03/27/2014 05:40 AM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

Originally posted by: stumped

why? Is there something else you have done to your computer that your not mentioning?

 

Do you have any notebook with Intel and AMD switchable graphics?

Did you try installing Leshcat drivers?

Do you know what is "Leshcat driver"?

 

My solution above with official Asus drivers works for me (and i've tried to install leshcat) and leshcat drivers - just an installer with drivers from intel and amd websites.

 

 03/27/2014 01:04 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

yes

yes

yes

Glad you fixed your problem. Problem with using drivers from the manufacturers is that you will get 2 maybe 3 updates from them and that's about it.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 03/27/2014 01:08 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Originally posted by: stlauren I try many configuration of installation. None works.

Either the CCC works with more recent drivers for HD8530M card, but will a big issue for computer wake-up (don't work), or the wake-up is OK, but not the CCC.

I believe it is an AMD issue when working in dual graphic configuration. It seems the issue is solve in recent upgrades, but not encapsuled by ASUS team for S301LP computer...

 

http://forums.amd.com/game/messageview.cfm?catid=492&threadid=172098&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 04/08/2014 09:46 AM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

Originally posted by: stlauren I tried your procedure. Don't work on my PC: always the same warning windows.

thank you in advance for your help...

 

stlauren, bios 208 is now available. There are 3 fixes: first fixes integrated video, another one L1 (something about PCI sleep/power state)... third is a new ASUS logo

 

I've updated with EasyFlash (from bios), but use USB drive formatted as FAT32 instead HARDDRIVE folder with NTFS.

 

update: Problem is back on Windows 8.1 Update 2014



Edited: 05/15/2014 at 04:13 PM by Romanov
 05/16/2014 10:36 AM
User is offline View Users Profile Print this message

Author Icon
xsanderex
Peon

Posts: 4
Joined: 05/16/2014

CCC can't detect videocard again? On your notebook?

I can't fix this issue.

If your found solution, please write it here.

 05/16/2014 01:25 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Again...laptops with switchable graphics can not use generic drivers. AMD offers generic drivers only. Use the supplied drivers from the laptop manufacturer or use the modded drivers from Leshcat. NOTE: You must have a set of working drivers from the manufacturer installed before using Leshcat. The other possibility is that your laptop does not support Windows 8.1. Even laptops that supported Windows 8 are not automatically supportive of Windows 8.1. Check with the laptop manufacturer, not Microsoft, to see if it supports a Windows 8.1 upgrade. If so, generally there is a bios update as well as drivers.

http://forums.amd.com/game/messageview.cfm?catid=448&threadid=161340&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *



Edited: 05/16/2014 at 02:00 PM by stumped
 05/16/2014 01:56 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

From Asus support:


 

 
 

 

Description
 Graphics Driver
"Prior to Windows 8.1 upgrade, please run Windows Update and install ALL updates, including optional updates, to minimize the risk of incompatibility.
After the upgrade, please run Windows Update again. If you still experience issue with this device, please install this driver. (This driver is for Windows 8.1 upgrade.)" 

File Size
163.45 MBytesupdate 2013/11/18 

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 05/16/2014 06:47 PM
User is offline View Users Profile Print this message

Author Icon
xsanderex
Peon

Posts: 4
Joined: 05/16/2014

I know it.
This driver is old version. He doesn't work.

Mb i do smth wrong...

 05/16/2014 07:00 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

I would try to install the 13.4 drivers from Asus. The newer drivers cause a black/or dim laptop screen. It does not affect a external monitor however. Have you tried using a monitor? 

Try these drivers from Asus...

Version  V10.18.10.3308.02

http://support.asus.com/download.aspx?SLanguage=en&p=3&s=425&m=S301LP&os=41&hashedid=9hx748K8hdxC6KQb



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *



Edited: 05/16/2014 at 07:06 PM by stumped
 05/19/2014 06:27 AM
User is offline View Users Profile Print this message

Author Icon
Romanov
Peon

Posts: 11
Joined: 08/29/2013

Looks like i've solved the main problems (access to AMD CC, display on|off and laptop power off) on Windows 8.1 Update 1.

 

Access to AMD Control Center

The problem: Can't access to AMD CC (error like: There is no adapter...)

1. Install clean Windows 8.1 and turn off automatic driver updates.

2. Turn off UAC and UEFI trusted module in BIOS

3. Install Chipset_Intel_Win81_64_VER9401027

4. Install MEI_Intel_15M_Win81_64_VER9601038

5. Install drivers from http://leshcatlabs.net/forums/viewtopic.php?f=6&t=376 (order -> Intel -> Amd)

Now you should have access to CC and setup switchable adapters.

 

Display (FN+F7) issue

The problem: Can't turn on display after pressing FN+F7

Do not install ATKPackage_Win81_64_VER100031

Default key for display on/off is working great.

 

Turning off laptop

The problem: Can't turn off notebook, or Windows reports crash after

1. Install all mising drivers from Asus website (CardReader, Intel Termal, Intel Smart Connect, etc.)

2. Turn off fast boot in Windows power settings and turn off additional power plans in AMD CC.

 

update: if lcd off is enabled in power settings... lcd goes off and you can't turn it on.

 



Edited: 05/20/2014 at 07:49 AM by Romanov
 05/21/2014 12:28 PM
User is offline View Users Profile Print this message

Author Icon
xsanderex
Peon

Posts: 4
Joined: 05/16/2014

Romanov

 Thank you!

I have some qestion:

 1)You installed this version: Catalyst_14.4_WHQL_UnifL_v1.3

 2)and you reboot your pc after each act or not, like this:

1.Install Chipset

2. reboot

3. Install Intel 
4. reboot
5. Install   Amd

6. reboot

3) System seeing you card like radeon R5 M240 or  HD8530m ?

Statistics
84705 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.