Topic Title: Radeon HD6720G2 viewed as HD6520G
Topic Summary:
Created On: 03/19/2014 07:50 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/19/2014 07:50 PM
User is offline View Users Profile Print this message

Author Icon
khoriami
Peon

Posts: 3
Joined: 03/19/2014

Hello,

I installed drivers with Catalyst and when I checked it said my graphic card was a Radeon HD 6520G but I have a Radeon HD6720G2 I think everything would be fine if I installed the default drivers back but I can't find them anywhere and the only thing I can download from AMD is Catalyst which put me in this mess.

As a result I have wild black stripes appearing on my screen when I seem to use too much GPU.

Can I have some help please ?

PS : I run on Windows 7 64bits and my computer is a Asus K53TA

 03/19/2014 08:14 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Go to Asus support and get the drivers for your model laptop.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 03/19/2014 08:25 PM
User is offline View Users Profile Print this message

Author Icon
khoriami
Peon

Posts: 3
Joined: 03/19/2014

But i can't find the correct driver, even on the asus support site. 

When i try to download the driver and install it, it says: Your computer does not contain a proper graphics adapter.

 03/19/2014 09:32 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Have you tried a system restore point from before you started messing with your graphics?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 03/19/2014 10:26 PM
User is offline View Users Profile Print this message

Author Icon
khoriami
Peon

Posts: 3
Joined: 03/19/2014

I dont have a system restore point, that was the first thing i tried.

I've installed windows 7 again and that's the point where everything went wrong. At first windows did not recognize my graphic card at all, dxdiag showed: standard VGA card. So i installed Catalyst for the drivers, now it says i've got the HD6520G it got a little better, but i just dont understand why HD6520G is showing instead of HD6720G2.

There is 1 thing i do know, my processor and graphic card are 1 together.  (i dont know how to explain this exactly)

Processor: AMD A6-3400 APU with Radeon(tm) HD Graphics (4CPUs) 1.4GHz

Statistics
84708 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.