Topic Title: Stuck at "Detecting graphics Hardware"
Topic Summary: Catalyst just get stuck at "Detecting Graphics Hardware" and I cannot proceed with installation
Created On: 04/16/2014 06:48 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/16/2014 06:48 AM
User is offline View Users Profile Print this message

Author Icon
GTMoraes
Peon

Posts: 6
Joined: 04/04/2013

Hey,
Graphics Card
- Built-in Radeon HD7650M. Laptop's LG N460

AMD Catalyst Driver Version, and Driver History
- I don't know which driver is it. It's the LG's Site one, must be pretty outdated. If it helps, I see that the "setup.exe" from 14.2 installer is Version 8.0.916.0, and the LG's one is 8.0.881.0.

Operating System
- Windows 8 64 Bits

Issue Details
- Cannot go past first phase of setup, gets stuck at "Detecting Graphics Hardware". The AMD Driver Download software (which automatically detects the card and downloads the correct driver for it) DOES detect it, just as the LG's installer does.
- Pic of the installer stuck 

Motherboard or System Make & Model
- LG N460-P.BG55P1

Power Supply

- It's the OEM charger, and OEM battery.

Display Device(s) and Connection(s) Used
- Built-in screen

Applications and Games

- AMD's installer

CPU Details
- Intel Core i5-3210M

Motherboard BIOS Version
LG3LR121  24/10/2012


System Memory Type & Amount
- 8GB DDR3 1333

Additional Hardware
- Uses a SSD.

Additional Details
- SSD shared with a desktop (swap between computer and laptop). Computer is Intel + nVidia and laptop is Intel + AMD. This SSD's Windows packs both AMD and nVidia Drivers, but I can't install the latest Catalyst drivers on the dedicated laptop HDD (with fresh windows) either.
- Windows is virus-free
- It isn't hardware related, as the LG drivers work.
- I've tried LG, AMD and UnifL drivers. Only LG's works and installs. The other two gets stuck during installation. LG's outdated so I need a solution.
- I've tried installing driver free and with LG Drivers. Didn't work.
------------
Ok, now with the "legal stuff" out of the way, let me write on my own:

This happens with AMD's Catalyst drivers and with UnifL drivers. The LG's one works, but I guess it's a bit outdated (2012).
I'd like to try out Mantle and have a more updated driver with 14.2 on my 7650M. 

I've tried a fresh install of the driver (fully wiping Catalyst and then deleting the drivers on Device Manager), I've tried to set the installer to "High performance" mode, I'm (obviously) trying to install while plugged in and in High performance, tried administrator mode, Windows 7 mode, tried the non-beta drivers and the beta drivers, UnifL and AMD's one but so far nothing. I could only install it by using the LG's Catalyst one. (here, if it's of any help: http://tinyurl.com/lhp5879)

Does anyone knows why it keeps stuck in that phase? It doesn't crash or anything, just gets stuck. I can't cancel either, so I have to force-close it on task manager. Is there somewhere I could grab logs of it (remember: it isn't crashing)
The driver is so outdated I can't even play Battlefield 4. It just shows a bunch of polygons flicking and rotating everywhere, at 9fps.

I've forced manually, through Device Manager, to the latest driver by choosing directly the .inf from the latest beta. Am I updated or do I need something else? I've noticed that this way, Catalyst force-closes every boot. It doesn't seems to be a very healthy solution.
 04/16/2014 09:39 AM
User is offline View Users Profile Print this message

Author Icon
GTMoraes
Peon

Posts: 6
Joined: 04/04/2013

Originally posted by: stumped Generally, that is caused by a anti-virus/anti-malware/anti-fill-in-the-blank. All should be disabled when trying to install anything. Do not use the 'auto-detect and install' thing..it's for dummies. Installing through device manager is a good/valid way to install...what do you mean by 'force closes'?

 

 

Hey,

 

Actually, no anti-virus. Or so to say, Microsoft Security Essentials. Can't believe this piece of software may be causing this lot of trouble, but I'll try disabling it.  Yeah, I do also share the thought that auto-detect drivers are for dummies, and I didn't use it in first place, but as the installer got stuck on "Detecting Graphics Hardware", I've tried every way to see if the hardware was visible or not (and it is visible).

Installing through Device Manager renders CCC unusable, as it "force-closes", as I said, and some essential features, like marking certain piece of software to use the "high performance GPU", unusable.
 And sorry about that, it's some wording I've learned to use by tinkering with smartphones. "Force-closing" is crashing, like in "CCC has stopped working. (A problem has caused... bla bla bla)"

 

I've read in other forums that updating the Intel driver first would fix this issue, and it did not fix it, unfortunately. I've tried every method of updating the Intel driver -- successfully actually -- but it doesn't seem to affect the AMD Driver installation. It still get stuck on Detecting Graphics Hardware (but the manufacturer, very outdated one doesn't). A shame, really. I'm still trying and losing way too much time on this.

 

--------------------

 

Okay, so I've read something in your edited post that caught my eye

 Laptops with 'switchable' graphics must use manufacturer supplied drivers.

This is a 'switchable' graphics. Like, automatic or something. I can't use the AMD one directly, it seems to be just a lone processor that does the heavy work for the Intel HD4000 and just pass the result for it to display. (Or this is what I understood by reading around the internets).

There are no switch buttons, no BIOS setting regarding this, there are no options on CCC to enable only the Radeon GPU (it says "High Performance mode" or "Battery Saving mode" or something along those lines).

This means I cannot update this way? I'm stuck with jurassic drivers?

---------

This:

picture

How screwed am I?  Btw those drivers being installed aren't AMD official one, but one called UnifL. You might have heard of it, it is supposed to be a special version designed by a dedicated user to be compatible with Intel + AMD laptops with switchable graphics.
Well, seems like my laptop is way too speshal for him. It's there since 2:52 hours ago 

-----

in an completely unrelated event, the forum posting is messed up. Why is my post ahead of yours?



Edited: 04/16/2014 at 09:57 AM by GTMoraes
 04/16/2014 01:29 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7035
Joined: 11/13/2009

Generally, that is caused by a anti-virus/anti-malware/anti-fill-in-the-blank. All should be disabled when trying to install anything. Do not use the 'auto-detect and install' thing..it's for dummies. Installing through device manager is a good/valid way to install...what do you mean by 'force closes'? These are the drivers I am using for my laptop..download these.

Here is my standard reply for a clean install:

To perform a 'clean install' of AMD graphics drivers:

1. IMPORTANT: All Windows Updates should be current, including the 'optional/suggested' updates
2. IMPORTANT: Disable all anti-virus/ad blockers/anti-malware/ anti-anything before trying to install
3. IMPORTANT: Netframework is required and must be the latest version. (from Windows Update)

Create a system restore point before, just in caes.

Download the drivers for your computer to the desktop. Follow steps 1-5 ( http://support.amd.com/en-us/download ).
 Do not use 'auto-detect and install.

Delete existing drivers from your computer:

In computer control panel select 'uninstall a program'
For computers with Intel processors:
Select AMD install manager and choose 'express uninstall all AMD software'
Including the install manager.

For computers with AMD processors:
Select AMD install manager and 'custom uninstall' the graphics drivers and CCC only.

Reboot into 'safe mode'
In safe mode run Driver Fusion  http://treexy.com/ (free version).
Select AMD graphics, analyse and delete all it finds.

Reboot

Install the new driver suite.

NOTE! Certain laptop configurations are not compatible with AMD's Mobility Catalyst™ Driver.
      AMD provides graphics drivers for most laptop brands and models for the Mobility Radeon™ HD series of graphics cards.
      If the AMD Mobility Radeon Driver Verification tool reports that the hardware is incompatible, then the notebook manufacturer is the exclusive provider of the graphics drivers for your notebook. (GPU-28041)
      Sony, Toshiba, and Panasonic will not accept generic drivers. Get drivers from manufacturers support site.
      Laptops with 'switchable' graphics must use manufacturer supplied drivers.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *



Edited: 04/16/2014 at 01:39 PM by stumped
 05/27/2014 09:38 PM
User is offline View Users Profile Print this message

Author Icon
Mike Bethany
Peon

Posts: 1
Joined: 05/27/2014

I had the same problem. I fixed it by uninstalling Air Display (a secondary monitor driver for your iPad).

So, see if you have anything like that installed as well.

Don't waste your time with Driver Fusion though, total gargabe.

Statistics
84158 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.