Topic Title: Asus R510DP Laptop 8670M Underclocking Itself
Topic Summary: The dedicated 8670M GPU on my Asus laptop is underclocking itself to about 400mhz for no apparent reason.
Created On: 06/16/2014 12:26 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/16/2014 12:26 PM
User is offline View Users Profile Print this message

Author Icon
bocajnotnef
Peon

Posts: 3
Joined: 06/16/2014

Right, so, I got this laptop about a week ago and have been intending to use it for basic computing and some light gaming. I didn't expect incredibly much out of the card but I was surprised when the APU was outperforming the dedicated card. In Borderlands 2 I was getting ~20 fps on the APU and about 9 fps on the GPU. Using MSI Afterburner and Asus GPU Tweak I found that the dedicated card was clocking itself to about 300 or 400mhz instead of the 775 the technical specs have it rated for. (Specs found here: http://products.amd.com/en-gb/MobilityGPUDetail.aspx?id=150&f1=&f2=&f3=&f4=&f5=&f6=&f7=&f8=&f9=&f10=&f11=&f12=&f13=&f14=&f15=&f16=&f17=&f18=&f19=&

As you'd imagine this is rather frustrating.

I've updated the drivers, I've double-checked that the applications involved are set to use the "high perfroamnce graphics" as stated in Catalyst. I've disabled/enabled the dual-graphics mode in Catalyst. I've made sure the laptop's power plan is set to high performance. I'm stumped, frankly.

 

Graphics Card
-ASUS manufactured Radeon HD 8670M

AMD Catalyst Driver Version, and Driver History
-Currently running 14.4, downloaded from ASUS support website

-Previously updated to latest version from AMD's driver support site, both manually selected and auto-detected.


Operating System
-Windows 8.1 64 bit, fully updated

Issue Details
-Experienced extremely low FPS in multiple games (Battlefield 3, Borderlands 2, Sins of a Solar Empire Rebellion), found GPU was underclocking itself to 400mhz.

-Steps to reproduce: Launch game, wait for crappy FPS

-All in-game settings set to 1080p resolution, no AA, no Vsync, low textures, etc.

Motherboard or System Make & Model
-ASUS R510DP Laptop

Power Supply

-Laptop, running on AC power.

Display Device(s) and Connection(s) Used

-You guessed it; Laptop.

Applications and Games

-Battlefield 3

-Borderlands 2

-Sins of a Solar Empire

CPU Details
-AMD A10-5750M, 4 cores at 2.5-3.5 GHz.

Motherboard BIOS Version
-No idea. Absolutely no information displayed at boot.

System Memory Type & Amount
-8 gigs of 1600 MHz ram; stock.

Additional Hardware
-Nothing special; all stock.

Additional Details
-AVG has scanned the system multiple times, found nothing of note.

 06/16/2014 12:59 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7457
Joined: 11/13/2009

This is due some power saving feature Asus has included in the bloatware that comes with the laptop....Power4Gear is one of them. It was one of the first things I deleted. It could be in the bios (like cool and quite). If your CCC has a power slider, set power to +20. You can disable ULPS...read this. In your computer power options, check advanced settings. Make sure you have the minimum processor state set to 100%.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 06/16/2014 02:36 PM
User is offline View Users Profile Print this message

Author Icon
bocajnotnef
Peon

Posts: 3
Joined: 06/16/2014

My CCC is extremely minimalist; There's no available power slider in there, though I amped up the one in MSI Afterburner to see if that would help. I also ran the ULPS disabling tool you linked to and that seems to have done something; The card will now accpet the overclock applied in Afterburner but it intermittently clocks itself back down to 400mhz and then cycles between the MSI overclock and the 400mhz while under load. 

In the power settings I found a Switchable Graphics Power Management that was set to Optimize Performance that I changed to Maximize Performance. I will continue testing to see if that helped as well. I also made sure that Minimum Processor State was set to 100%

 06/16/2014 04:14 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7457
Joined: 11/13/2009

You didn't mention anything about overclocking in your first post. There is your problem. That laptop runs hot to start with, overclocking just makes it worse. Heat is what is causing the clocks to revert. The laptop should play modern games at low settings....a $600 laptop is not designed for gaming at med-high settings, and trying to make it by overclocking is going to bring you grief.

Read this

http://www.notebookcheck.net/AMD-Radeon-HD-8670M.87211.0.html

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *



Edited: 06/16/2014 at 04:26 PM by stumped
 06/16/2014 11:18 PM
User is offline View Users Profile Print this message

Author Icon
bocajnotnef
Peon

Posts: 3
Joined: 06/16/2014

I'm fully aware that overclocking would cause problems; The OC is only set to the design specs of the card (775 mhz) and the card isn't even reaching any high temps anyway--It hangs around 62 C pretty much all the time. And the card starts at 400 mhz--It's not like I start playing and then it drops, it's at 400 when the game first launches. 

I'm not expecting my machine to perform exceptionally well, but it should give me better than 9 frames per second running borderlands 2 with every advanced graphics option disabled on a dedicated GPU at 720p. 

 06/20/2014 10:43 PM
User is offline View Users Profile Print this message

Author Icon
XxMayhem714xX
Peon

Posts: 1
Joined: 06/20/2014

The main problem i have noticed with this laptop is the drivers.  Make sure you are using the Asus proprietary driver ccc Version  V12.100.19.0.  I have tried some other drivers like 13.1 and 14.4 with no avail.  when using the new drivers i actually get an fps drop, also do not update to windows 8.1 because the driver support sucks

Make sure you use your serial number when download the drivers, the laptop has the same motherboard as the x550dp which one driver worked pretty well but not as well as the 12.1

i play a lot of games bf3, bf4, bf hardline beta, loadout, smite, league of legends, titanfall most games run at 1280x720 at low or medium settings.  the MOBA games run at full 1080p at ultra

Statistics
87559 users are registered to the AMD Support and Game forum.
There are currently 10 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.