Topic Title: Screen going dark and not turning on after reboots
Topic Summary:
Created On: 06/19/2014 04:09 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/19/2014 04:09 AM
User is offline View Users Profile Print this message

Author Icon
WhyAMDWhy
Peon

Posts: 2
Joined: 06/19/2014

I just downloaded and executed a driver update for my 7xxxM radeon on my laptop, while the program was running, it had a warning that my screen might flikker and go dark while installing, but after 30 minutes of waiting, nothing showed. I rebooted and now the screen is not turning on. What can I do about this...

 06/19/2014 12:11 PM
User is offline View Users Profile Print this message

Author Icon
backFireX64
Elite

Posts: 1044
Joined: 11/14/2010

Boot to safe mode, uninstall gpu drivers and try again a clean install of the latest or previous supported drivers.



-------------------------

gigabyte X58A-UD3R rev.2, core i7 975 3.9ghz (stock voltage), windows 8.1 64-bit, corsair 12gb DDR3 1600mhz 7-7-7-20 RAM, xfx HD 5970 + gigabyte HD 5970 (stock clocks), coolermaster ultimate 900w PSU.
amd catalyst 14.7 RC3 aug12

 06/19/2014 04:46 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Originally posted by: WhyAMDWhy I just downloaded and executed a driver update for my 7xxxM radeon on my laptop, while the program was running, it had a warning that my screen might flikker and go dark while installing, but after 30 minutes of waiting, nothing showed. I rebooted and now the screen is not turning on. What can I do about this...

 

Is this a Asus laptop?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 06/21/2014 11:04 PM
User is offline View Users Profile Print this message

Author Icon
Zhatun
Peon

Posts: 3
Joined: 06/21/2014

Not OP but i have the same issue and yes my laptop is from Asus

Edit: i know the driver from asus homepage fixes it but i dont wanna run around with a 3 year old driver

 06/21/2014 11:43 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Originally posted by: Zhatun Not OP but i have the same issue and yes my laptop is from Asus

 

Edit: i know the driver from asus homepage fixes it but i dont wanna run around with a 3 year old driver

 

Then you better fill out a issue report. This has been a bug for quite awhile...using 13.4 works. If you use a external moniter everything is fine...it's just the laptop screen that doesn't work...and it's only Asus laptops.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 06/22/2014 07:14 AM
User is offline View Users Profile Print this message

Author Icon
Zhatun
Peon

Posts: 3
Joined: 06/21/2014

Yeah i've already done that like a month ago or so, been lurking for quite a while and found it in another thread.

I think i tried 13.4 once and if memory serves correctly it didnt work.

Maybe you can link me to the correct 13.4 driver please?

Thanks

 06/22/2014 08:09 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

13.4 Mobility

 

To install new AMD graphics drivers:

1. IMPORTANT: All Windows Updates should be current, including the 'optional/suggested' updates
2. IMPORTANT: Disable all anti-virus/ad blockers/anti-malware/ anti-anything before trying to install
3. IMPORTANT: Netframework is required and must be the latest version. (from Windows Update)

 
Create a system restore point before, just in case.

Download the drivers for your computer to the desktop. Follow steps 1-5 ( http://support.amd.com/en-us/download ).
 Do not use 'auto-detect and install.

Delete existing drivers from your computer:

In computer control panel select 'uninstall a program'

For computers with Intel processors:
Select AMD install manager and choose 'express uninstall all AMD software'
Including the install manager.

For computers with AMD processors:
Select AMD install manager and 'custom uninstall' the graphics drivers and CCC only.

Reboot

Install the new driver suite.

Reboot



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 06/22/2014 02:17 PM
User is offline View Users Profile Print this message

Author Icon
Zhatun
Peon

Posts: 3
Joined: 06/21/2014

holy crap the 13.4 mobility driver really did the job

didnt expected anything but yay finally i have dual monitor again =)

thanks man

Statistics
84699 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.