Topic Title: Switchable graphics not working on Lenovo G505s
Topic Summary:
Created On: 07/24/2014 07:14 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/24/2014 07:14 AM
User is offline View Users Profile Print this message

Author Icon
Mute
Peon

Posts: 3
Joined: 07/24/2014

So I've come to notice that on my Lenovo, the dedicated GFX card (HD 8570M) doesn't seem to be used at all, even when I set the switchable graphic option to 'High Performance', the monitor reports it using the power saver option. Using OpenHardwareMonitor, it doesn't report any temperature or load at all.

I've tried with a few games (don't have many accessible right now), such as Metro 2033, Left 4 Dead 2 and Saints Row 4. I thought the first two were because the games were old, but the fact that Saints Row 4 doesn't use the dedicated GPU baffles me.

The integrated GPU is an 8650G from the AMD A10-5750M APU.

I've tried asking for assistance on the Lenovo forums, but got no response.

 07/24/2014 08:25 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7852
Joined: 11/13/2009

Disable the IGP in the bios. There should be a graphics option there, change it to 'fixed' or 'static'. Did this start happening since you tried to update your cards?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 


***** cetera fallunt, ludere mortuus ******

 07/24/2014 09:32 AM
User is offline View Users Profile Print this message

Author Icon
Mute
Peon

Posts: 3
Joined: 07/24/2014

Originally posted by: stumped Disable the IGP in the bios. There should be a graphics option there, change it to 'fixed' or 'static'. Did this start happening since you tried to update your cards?

That's also one thing. I've looked in the BIOS, and there is no option to disable the IGPU. Only two options exist, 'Switchable Graphics', which is currently selected, and 'UMA only' as the other, which only uses the integrated gpu.

I first noticed this before updating the drivers, so I tried using the latest generic mobility drivers, but they didn't work, so I re-installed the drivers from the Lenovo site for this laptop, and still no avail.

 07/25/2014 04:43 PM
User is offline View Users Profile Print this message

Author Icon
Mute
Peon

Posts: 3
Joined: 07/24/2014

A minor update, but it seems Dota 2 actually uses the dedicated GPU. Does this mean it's an issue with the games? I've also noticed that they don't use the dedicated GPU when I try to use the Dual Graphics option.

Statistics
88967 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.