Topic Title: Catalyst Update Error HD Radeon 4850
Topic Summary:
Created On: 08/23/2012 11:05 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/23/2012 11:05 PM
User is offline View Users Profile Print this message

Author Icon
TheSeeker
n00b

Posts: 3
Joined: 08/23/2012

I currently have an HD Radeon 4850 1gb on this machine.  This appears to be a major issue for me, I currently have Catalyst 11.7.  Whenever I decide to update it, it uninstalls fine, and then reports an error after I have finished updating, although the log does not specify where the error is, because it indicates everything is fine.  After directed to restart my PC, Windows 7 Home Premium loads up, but appears unstable.  As soon as I launch a program (such as google chrome or World of Tanks), Windows crashes and my GPU fan immediately speeds up to it's maximum capacity and the screen goes black, or pixelated (resembles a broken video card...), in which I then reset my PC and change to internal graphics again on the BIOS, and revert catalyst back to 11.7.  On my other PC, I have a 4850 512mb, and it updates perfectly fine.  Are my drivers corrupt, or is it a hardware limitation with this particular model?  I am also concerned about the fact that my computer has Direct X11 installed, but my video card only supports Direct X10.  I am also unable to attach my DxDiag report.

System info:

Video Card: XFX HD Radeon 4850 1gb

CPU: Intel Core i5 First Generation 2400 @ 3.10GHz

Operating System: Windows 7 Home Premium

Motherboard: Gigabyte Z68X-UD3H-B3

RAM: 2x 2gb Corsair DDR3 Modules

I also have Intel On-Board Graphics, but I'm not certain about what model it is.



Edited: 08/24/2012 at 12:56 PM by TheSeeker
 08/24/2012 02:40 AM
User is offline View Users Profile Print this message

Author Icon
schorschi
n00b

Posts: 4
Joined: 04/15/2011

I have a similar problem, I have embedded 4290, and two 5450s.  Cat 12.6 works, although I do have the dropped Audio over HDMI issue off and on, which is a well documented and discussed issue that ATI seems to still be trying to resolve completely.  But with 12.8, the 4290 driver (07/03/2012) fails to load completely, but the 5450s do load the (7/25/2012) driver.  No matter what I try, I can't get 4290 to work right with Cat 12.8.  I had to back out back to 12.6, but the back out appears to leave some of the newer drivers in place but not others.  If I let the system discover the 4290 it will consistently find the 07/03/2012, version 8.970.100.3000 driver, even though 12.6 installed, and it works!  But then the 5450s use a funky 8.21.0.0 (01/26/2011) driver? We appears to work, but once in a while I get the classic BSOD ati 116 error.

I can get the 4290 recognized in the device manager, under 12.8 sometimes, but no connected monitors of any type HDMI or VGA connected to the 4290 are ever discovered.  But the 5450s using 7/25/2012 drivers work fine.  I don't have any DVI monitors to test that method on the 5450s but HDMI and VGA work.

Either 12.6 works with very old 5450 drivers (

Using Cat 12.6 working 5450s... 01/26/2011, version 8.821.0.0. 4290 working... 07/03/2012, version 8.970.100.3000, and 4290 works as noted above with 12.8 driver but 12.6 installed...

OR...

12.8 the 5450s work, but the 4290 either fails to load the driver (device manager reports error 43), or even if the driver loads for the 4290, no monitor connected to the 4290 (HDMI or VGA) is recognized.

AMD/ATI, what the heck is going on?

ASUS M89AGTD mainboard, with 16GB RAM, AMD x6 core T1075 processor, Windows 7 64bit fully patched, current

Before attempting to install 12.8 original drivers 4290 and 5450 cards used the 4/05/12 or 4/25/12 drivers respectively.  After roll-back from 12.8, the very old 5450 drivers appeared, and the 4290 still used the newer driver.

This issue is consistent, I installed 12.8 several times, always the same behavior as noted above.  I installed 12.6 several times, always the same behavior as noted above.

 Finally after hours to trying to get 12.8 to work... I gave up.  I am beginning to believe, many of the Google comments about ATI, that the driver quality has gone in the wrong, horrible, direction, in reference to quality.  Which is sad, I have used ATI for over 8 years, and had a positive experience, but in the last 18 months, especially with the 12.x Cat series, well, it stinks, is all I can say.



Edited: 08/24/2012 at 02:53 AM by schorschi
 08/24/2012 02:56 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7253
Joined: 11/13/2009

Discussed to death on this forum.....pre 5xxx cards are legacy now. No dx11, no support. 12.8 does not support pre 5xxx cards. 12.8 does not support 2xxx, 3xxx, or 4xxx cards. The latest driver set for 4xxx is 12.6. If you look right here > http://support.amd.com/us/gpudownload/Pages/index.aspx  < you see that 2xxx, 3xxx, and 4xxx have a different section. 5xxx, 6xxx, and 7xxx use different drivers that are not designed to work on pre-5xxx cards. Not only that, but there is no pre- 5xxx support for Windows 8. Do a 'search' in this forum or google.

maybe this is clearer > http://www.anandtech.com/show/5775/amd-hd-2000-hd-3000-hd-4000-gpus-being-moved-to-legacy-status-in-may



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *



Edited: 08/24/2012 at 03:19 AM by stumped
 08/24/2012 11:57 AM
User is offline View Users Profile Print this message

Author Icon
TheSeeker
n00b

Posts: 3
Joined: 08/23/2012

Sorry for not being clearer, but when I bought my card, the CD came with catalyst 12.4.  I was rather shocked that the card was already broken, so I went through several forums and reverted the driver back to 11.4: the card worked fine.  I bought BF3 a while ago, and it required 11.7, so I updated to it fine.  I then noticed graphics glitches in World of Tanks, and I was told to upate to 12.6 Legacy Version, I reeinstalled Catalyst, but only got the same error.  So any normal OR legacy version past 11.7 will not work on this PC.  On my other 4850, there is no such problem when updating, which I find strange.

 08/24/2012 12:00 PM
User is offline View Users Profile Print this message

Author Icon
TheSeeker
n00b

Posts: 3
Joined: 08/23/2012

Yeah, I hated the Windows 8 preview, I'll go back to XP if I can find a place to get it where it's not $400.

Statistics
85759 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.