Topic Title: Need help on my ati 4650 pls
Topic Summary: persistent flickering on my monitor
Created On: 09/11/2012 12:14 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/11/2012 12:14 AM
User is offline View Users Profile Print this message

Author Icon
cherrydee
n00b

Posts: 1
Joined: 09/10/2012

hi so i have a 5yr old PC and last sunday night, my monitor suddenly flickers with purple/green shapes randomly and i also get the message "driver has stopped working and has been recovered successfully". there are also times my pc freezes for ~30sec or sometimes my monitor goes blank (blinking power on led).

so my initial response was to open my casing, replug my video card and make sure the screw is tight, turn on my pc and its fine again.

but last night, the problem went back again, this time replugging the video card didn't solved my problem. so what i did was uninstall my video card from device manager, the flicker went away so i restarted my PC to install a new updated driver. but now i was stuck at the windows 7 logo. took 15min to get to log on screen. and after typing my password i never reached the desktop. safe mode also stuck at log on part.

SORRY for the wall of text. got some questions:
1. when i uninstalled my driver and flicker went away does that mean the problem is with the driver? or the video card still might be at fault?
2. why am i stuck at windows logo and log on screen? is this the effect of a no-driver-video card? though i know it's not
3. ok so after 12hrs, i opened my pc again and voila, no flicker, fast rebooting, all seems perfect. so what do you guys think the problem is? overheat? vcard needs rest?

note: i play online games for atleast 10hrs a day (if no school/work).

bonus question: any recommended video card for $60?

 09/11/2012 06:56 AM
User is offline View Users Profile Print this message

Author Icon
zipsi
Case Modder

Posts: 922
Joined: 11/22/2010

For $60 you aint getting nothing practical, perhaps a htpc gpu that can run no games.

To find out whats wrong with your system, you should first read the **STICKY** | PLEASE READ BEFORE POSTING post and provide us the information mentioned there, otherwise we would be just guessing blind.



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
Statistics
80925 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.